summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-04 10:46:00 +0100
committerSam James <sam@gentoo.org>2022-10-04 10:46:05 +0100
commit7ec5c9ec7ea0fc9ca1d52559dcb2109ab30fc453 (patch)
treec2783557203e11ded39dc22fa308510d9e3ccac6 /net-analyzer
parentdev-java/easymock: update EAPI 7 -> 8 (diff)
downloadgentoo-7ec5c9ec7ea0fc9ca1d52559dcb2109ab30fc453.tar.gz
gentoo-7ec5c9ec7ea0fc9ca1d52559dcb2109ab30fc453.tar.bz2
gentoo-7ec5c9ec7ea0fc9ca1d52559dcb2109ab30fc453.zip
net-analyzer/ike-scan: fix openssl path
TODO: pkgconfig, but I'm not up for that fight right now. Closes: https://bugs.gentoo.org/874711 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ike-scan/files/ike-scan-1.9.5-openssl-libdir.patch55
-rw-r--r--net-analyzer/ike-scan/ike-scan-1.9.5.ebuild4
2 files changed, 58 insertions, 1 deletions
diff --git a/net-analyzer/ike-scan/files/ike-scan-1.9.5-openssl-libdir.patch b/net-analyzer/ike-scan/files/ike-scan-1.9.5-openssl-libdir.patch
new file mode 100644
index 000000000000..0ee12dc2f907
--- /dev/null
+++ b/net-analyzer/ike-scan/files/ike-scan-1.9.5-openssl-libdir.patch
@@ -0,0 +1,55 @@
+TODO: switch to pkgconfig
+--- a/configure.ac
++++ b/configure.ac
+@@ -187,49 +187,9 @@ AC_ARG_WITH(openssl,
+ [
+ if test "x$withval" != "xno" ; then
+ AC_MSG_RESULT(yes)
+- for ssldir in $withval /usr/local/ssl /usr/lib/ssl /usr/ssl /usr/pkg /usr/local /usr; do
+- if test -f "${ssldir}/include/openssl/ssl.h"; then
+- found_openssl="yes"
+- openssl_header_dir="${ssldir}/include"
+- AC_MSG_NOTICE([Found ${ssldir}/include/openssl/ssl.h])
+- break
+- fi
+- if test -f "${ssldir}/openssl/ssl.h"; then
+- found_openssl="yes"
+- openssl_header_dir="${ssldir}"
+- AC_MSG_NOTICE([Found ${ssldir}/openssl/ssl.h])
+- break
+- fi
+- done
+- if test x$found_openssl != xyes; then
+- AC_MSG_ERROR([Cannot find OpenSSL header files])
+- else
+- AC_MSG_NOTICE([OpenSSL header files found in $openssl_header_dir])
+- CPPFLAGS="-I${openssl_header_dir} ${CPPFLAGS}"
+- fi
+- if test -f "${ssldir}/lib/libcrypto.so"; then
+- openssl_lib_dir="${ssldir}/lib"
+- AC_MSG_NOTICE([Found ${ssldir}/lib/libcrypto.so])
+- elif test -f "${ssldir}/libcrypto.so"; then
+- openssl_lib_dir="${ssldir}"
+- AC_MSG_NOTICE([Found ${ssldir}/libcrypto.so])
+- elif test -f "${ssldir}/lib/libcrypto.dylib"; then
+- openssl_lib_dir="${ssldir}/lib"
+- AC_MSG_NOTICE([Found ${ssldir}/lib/libcrypto.dylib])
+- elif test -f "${ssldir}/libcrypto.dylib"; then
+- openssl_lib_dir="${ssldir}"
+- AC_MSG_NOTICE([Found ${ssldir}/libcrypto.dylib])
+- elif test -f "${ssldir}/lib/libcrypto.a"; then
+- openssl_lib_dir="${ssldir}/lib"
+- AC_MSG_NOTICE([Found ${ssldir}/lib/libcrypto.a])
+- elif test -f "${ssldir}/libcrypto.a"; then
+- openssl_lib_dir="${ssldir}"
+- AC_MSG_NOTICE([Found ${ssldir}/libcrypto.a])
+- else
+- openssl_lib_dir="${ssldir}/lib"
+- AC_MSG_NOTICE([Cannot find libcrypto under $ssldir - assuming its in the standard search path])
+- fi
+ AC_MSG_NOTICE([OpenSSL libraries found in $openssl_lib_dir])
++ openssl_header_dir="${withval}/include/openssl"
++ CPPFLAGS="${CPPFLAGS} -I${openssl_header_dir}"
+ LDFLAGS="-L${openssl_lib_dir} ${LDFLAGS}"
+ LIBS="-lcrypto ${LIBS}"
+
diff --git a/net-analyzer/ike-scan/ike-scan-1.9.5.ebuild b/net-analyzer/ike-scan/ike-scan-1.9.5.ebuild
index acfffd464bb0..7f1d570df837 100644
--- a/net-analyzer/ike-scan/ike-scan-1.9.5.ebuild
+++ b/net-analyzer/ike-scan/ike-scan-1.9.5.ebuild
@@ -19,6 +19,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-1.9.5-clang-16.patch
+ "${FILESDIR}"/${PN}-1.9.5-openssl-libdir.patch
)
src_prepare() {
@@ -33,7 +34,8 @@ src_prepare() {
}
src_configure() {
- econf $(use_with ssl openssl)
+ econf \
+ $(use_with ssl openssl "${ESYSROOT}"/usr)
}
src_install() {