summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-02-07 16:51:35 +0100
committerJeroen Roovers <jer@gentoo.org>2017-02-07 16:51:35 +0100
commit89d75131329a93fa67348749b03173485eedad16 (patch)
tree581a223f91240ac442f605e5bcff5547b839d2f8 /net-analyzer
parentnet-analyzer/cacti: Version bump. (diff)
downloadgentoo-89d75131329a93fa67348749b03173485eedad16.tar.gz
gentoo-89d75131329a93fa67348749b03173485eedad16.tar.bz2
gentoo-89d75131329a93fa67348749b03173485eedad16.zip
net-analyzer/cacti-spine: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.0.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index 03adbcd0a763..04afb572e902 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1,2 +1,3 @@
DIST cacti-spine-0.8.8h.tar.gz 804951 SHA256 a693136839bd7d03cae5b3ff4614a4d21a2153ffb14d09fc061b843ab0b2bb30 SHA512 6a7147ab645be44de0d330c7801e569705817da10bf6cedba82c712e1701ada8aa8924a6b3b063ea680e6af24f815d6767e8773ad7b8da212abfa082b4211bd4 WHIRLPOOL 36daed4986ca84883e51ab6b02ebb2ade00205c30705cfc94e73835bc2fc427a60a2dba9c7ca3665d0c0b2fca21afab77d94cde63b740f3734f9279c929cccaf
DIST cacti-spine-1.0.0.tar.gz 800770 SHA256 074528eec16e8a49d535ce96d2347bd2a891a56722b261d744225d9f90b6382f SHA512 458b0050ceff3a9e2d31c54c177d75f8d36ff521204d5f7b52a5fb9ff6082c25ef98f46d80dc6c79816e5a977f5b61decac03b625728fc9dc654170e3ce3e87f WHIRLPOOL 3c24d028606ab382ea61feeecda141c96d6b2a588247656285bbb832e309d1e6acd086a8464c9083cc19c777fcd0e15bff53aad417d8889e3b08a85aa38b5be1
+DIST cacti-spine-1.0.1.tar.gz 800797 SHA256 75b699bd4a85389a4fe026423aae97b51e9f6b091cffbfb6b41d5785d7423330 SHA512 c5b2f22c6304f5a95e3db58609fb430fc3fb1ba01de6a0817bc6d86ea94af791e55a4985496980b472ce88723ee498dbb4e8a004be4d41e61b795a7b510af999 WHIRLPOOL a67b29de02b0b21cdd65c8c1aefd89a1b0c74eff4ab7dcb6395ed2bff8d0d14f32c579df8c55adca0e3b6c1d9dd01693b19db54efdb80ec10042913bcfc4cef7
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.0.1.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.0.1.ebuild
new file mode 100644
index 000000000000..1dbd7773e31b
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="http://cacti.net/spine_info.php"
+SRC_URI="http://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ dev-libs/openssl:*
+ net-analyzer/net-snmp
+ virtual/mysql
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+ dodoc ChangeLog
+}