summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-07 11:31:07 +0000
committerSam James <sam@gentoo.org>2021-01-07 11:33:22 +0000
commit9096ebebeb09dcf200144e255374186d7d260ab9 (patch)
tree7367e231afcaa88ffdad051668c580c8b7a20e54 /net-analyzer
parentnet-analyzer/hping: cleanup old (diff)
downloadgentoo-9096ebebeb09dcf200144e255374186d7d260ab9.tar.gz
gentoo-9096ebebeb09dcf200144e255374186d7d260ab9.tar.bz2
gentoo-9096ebebeb09dcf200144e255374186d7d260ab9.zip
net-analyzer/hping: cleanup old
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch16
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-scan-overflow.patch11
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-strlen.patch11
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105.patch45
4 files changed, 0 insertions, 83 deletions
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch b/net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch
deleted file mode 100644
index 39814bff0d8c..000000000000
--- a/net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -50,11 +50,11 @@
- $(RANLIB) $@
-
- hping3: byteorder.h $(OBJ)
-- $(CC) -o hping3 $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@
-+ $(CC) -o hping3 $(CCOPT) $(LDFLAGS) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@
- @echo
-
- hping3-static: byteorder.h $(OBJ)
-- $(CC) -static -o hping3-static $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@ -ldl
-+ $(CC) -static -o hping3-static $(CCOPT) $(LDFLAGS) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@ -ldl
-
- byteorder.h:
- ./configure
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-scan-overflow.patch b/net-analyzer/hping/files/hping-3_pre20051105-scan-overflow.patch
deleted file mode 100644
index 2c3e01bf697a..000000000000
--- a/net-analyzer/hping/files/hping-3_pre20051105-scan-overflow.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/scan.c
-+++ b/scan.c
-@@ -456,7 +456,7 @@
- continue;
- /* time to copy headers in a safe place */
- p = packet+linkhdr_size+iphdrlen;
-- memcpy(&icmp, p, sizeof(subtcp));
-+ memcpy(&icmp, p, sizeof(icmp));
- p += sizeof(icmp);
- memcpy(&subip, p, sizeof(ip));
- p += sizeof(ip);
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-strlen.patch b/net-analyzer/hping/files/hping-3_pre20051105-strlen.patch
deleted file mode 100644
index 692cd93102fb..000000000000
--- a/net-analyzer/hping/files/hping-3_pre20051105-strlen.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/ip_opt_build.c
-+++ b/ip_opt_build.c
-@@ -25,7 +25,7 @@
- unsigned char optlen = 0;
- unsigned long ip;
-
-- memset(ip_opt, 1, sizeof(ip_opt));
-+ memset(ip_opt, 1, strlen(ip_opt));
-
- if (opt_lsrr)
- {
diff --git a/net-analyzer/hping/files/hping-3_pre20051105.patch b/net-analyzer/hping/files/hping-3_pre20051105.patch
deleted file mode 100644
index e3133f2b6b42..000000000000
--- a/net-analyzer/hping/files/hping-3_pre20051105.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- a/libpcap_stuff.c
-+++ b/libpcap_stuff.c
-@@ -17,7 +17,7 @@
- #include <stdlib.h>
- #include <sys/ioctl.h>
- #include <pcap.h>
--#include <net/bpf.h>
-+#include <pcap-bpf.h>
-
- #include "globals.h"
-
---- a/script.c
-+++ b/script.c
-@@ -24,7 +24,7 @@
-
- #include <sys/ioctl.h>
- #include <pcap.h>
--#include <net/bpf.h>
-+#include <pcap-bpf.h>
-
- #include "release.h"
- #include "hping2.h"
---- a/configure
-+++ b/configure
-@@ -93,7 +93,7 @@
- else
- USE_TCL=""
- TCL_LIB=""
-- echo "==> WARNING: no Tcl header files found!"
-+ echo "==> WARNING: no Tcl header files found."
- fi
- fi
- if [ -n $USE_TCL ]
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -52,9 +52,6 @@
- hping3: byteorder.h $(OBJ)
- $(CC) -o hping3 $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@
- @echo
-- ./hping3 -v
-- @echo "use \`make strip' to strip hping3 binary"
-- @echo "use \`make install' to install hping3"
-
- hping3-static: byteorder.h $(OBJ)
- $(CC) -static -o hping3-static $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@ -ldl