summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-09-18 13:00:47 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-09-18 13:00:47 +0200
commit9f4a9914eae52b1738306aca68b5818c03a58ad2 (patch)
treed2c3a9f3481ca93be3a6c912ce12f09dec155aa7 /net-analyzer
parentnet-analyzer/prometheus-node_exporter: Remove old (diff)
downloadgentoo-9f4a9914eae52b1738306aca68b5818c03a58ad2.tar.gz
gentoo-9f4a9914eae52b1738306aca68b5818c03a58ad2.tar.bz2
gentoo-9f4a9914eae52b1738306aca68b5818c03a58ad2.zip
net-analyzer/prometheus: Version bump to 2.0.0_beta4, fix initscripts
Gentoo-Bug: 631142 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/prometheus/Manifest1
-rw-r--r--net-analyzer/prometheus/files/prometheus-3.initd19
-rw-r--r--net-analyzer/prometheus/prometheus-2.0.0_beta4.ebuild68
3 files changed, 88 insertions, 0 deletions
diff --git a/net-analyzer/prometheus/Manifest b/net-analyzer/prometheus/Manifest
index 5a0a972cfd5c..6d9c26530726 100644
--- a/net-analyzer/prometheus/Manifest
+++ b/net-analyzer/prometheus/Manifest
@@ -1,2 +1,3 @@
DIST prometheus-1.7.1.tar.gz 5122747 SHA256 209832310f5bef99faef3beaaa95263612a4d0126ca512c4a4c23a8543d3ccf5 SHA512 98a42e95978477530082d7549c29f17b133043d7c233ba3c90b183f06a3f24ee578f8fed75cba476d3c93a22abcccfdbccc94488beb8450a02f260d24165ba26 WHIRLPOOL 8ab473430752336e09b4a0c38fd1117abe21196478d7f2f7e813c27f07c950cc3525d9e9ba32309711c73a1032f3cff27ddc1582d0c4b6c66fe82d5b58675550
DIST prometheus-2.0.0_beta2.tar.gz 5521490 SHA256 d8d54562209ff33f9a831e4de7ac0bc94dc743f9ed78d413437750c338d369a2 SHA512 27366ee07428a70cf142036dee4b7f9e24d135d017f6423ffb2fbea648d0601c2e14e927e1bccef5da7e2a2be9b47963e18d02d2759375a05a8b332a0733c1c5 WHIRLPOOL 860fa895ccfc60b08bb76510be4d15272e8b453a46f3af60c4c012e6319c9172762ae27b9bbf6192d73d81d402fd49f3b8b6869f5fc2a496c49345c204207c56
+DIST prometheus-2.0.0_beta4.tar.gz 5534359 SHA256 81196ea9d678c339ba592f29c0f0bdf6bd050862065c5b45351588dc47efbbce SHA512 2d2727e34cb6d71ba4ac431d3300a47482522c115f602358ce77c3ababb2defeec863d10d8cffc0325be0a9dde16e7c3beeed9a0f3c7b6b3b0db86e77e715b6c WHIRLPOOL 52abc94fa55d52e49d3da6a10e6504e07e5cafd635f7c337b941939ee5ff4a112dc7dfee0bfa96ae99086da9f2b14fb79eedb36158f4c0a746a77d3b158d386d
diff --git a/net-analyzer/prometheus/files/prometheus-3.initd b/net-analyzer/prometheus/files/prometheus-3.initd
new file mode 100644
index 000000000000..5f6d6fe14267
--- /dev/null
+++ b/net-analyzer/prometheus/files/prometheus-3.initd
@@ -0,0 +1,19 @@
+#!/sbin/openrc-run
+# Copyright 2016-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="Prometheus monitoring system and time series database"
+pidfile=${pidfile:-"/run/${RC_SVCNAME}.pid"}
+user=${user:-${SVCNAME}}
+group=${group:-${SVCNAME}}
+
+command="/usr/bin/prometheus"
+command_args="${command_args:---config.file=/etc/prometheus/prometheus.yml --storage.tsdb.path=/var/lib/prometheus/data}"
+command_background="true"
+start_stop_daemon_args="--user ${user} --group ${group} \
+ --stdout /var/log/${RC_SVCNAME}/${RC_SVCNAME}.log \
+ --stderr /var/log/${RC_SVCNAME}/${RC_SVCNAME}.log"
+
+depend() {
+ after net
+}
diff --git a/net-analyzer/prometheus/prometheus-2.0.0_beta4.ebuild b/net-analyzer/prometheus/prometheus-2.0.0_beta4.ebuild
new file mode 100644
index 000000000000..919309ad8114
--- /dev/null
+++ b/net-analyzer/prometheus/prometheus-2.0.0_beta4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=${PV/_beta/-beta.}
+EGIT_COMMIT="v${MY_PV}"
+PROMETHEUS_COMMIT="1b80f63"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus-3.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_beta4'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}