summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2018-01-03 09:48:15 +0100
committerJonas Stein <jstein@gentoo.org>2018-01-03 09:48:15 +0100
commitbe38db17570297340b2356ec5651d797001d2f8c (patch)
treea9080d19212b2868fb93d612d997aa654c7166fc /net-analyzer
parentdev-python/Kivy: Patch fixing bug with sdl-mixer (diff)
downloadgentoo-be38db17570297340b2356ec5651d797001d2f8c.tar.gz
gentoo-be38db17570297340b2356ec5651d797001d2f8c.tar.bz2
gentoo-be38db17570297340b2356ec5651d797001d2f8c.zip
net-analyzer/aimsniff: Drop last rited package
Bug: https://bugs.gentoo.org/638564
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/aimsniff/Manifest2
-rw-r--r--net-analyzer/aimsniff/aimsniff-0.9d.ebuild109
-rw-r--r--net-analyzer/aimsniff/files/aimsniff.rc18
-rw-r--r--net-analyzer/aimsniff/metadata.xml12
4 files changed, 0 insertions, 141 deletions
diff --git a/net-analyzer/aimsniff/Manifest b/net-analyzer/aimsniff/Manifest
deleted file mode 100644
index 82dc4057f6d9..000000000000
--- a/net-analyzer/aimsniff/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST aimsniff-0.9d.tar.gz 24044 BLAKE2B 7b6bfd0fc80996b7cfdd5908e4c28cd57980d29c98cc164c27ce77d0b66a2802a6e180f19f2b5971690b272e5ed9959fd104d3be17e3d9e8748b3acb57c24542 SHA512 eba8d1ff21c6c841f5e1b344769c38bf00936613c975dd60e0c3922e67805733c2e949006be36a83d75fc6c9c77de510a6914d184c6159e46b9d35cc4f12efa6
-DIST was-0.1.2b.tar.gz 73651 BLAKE2B 400fa2181c36df5e525d446c636ffb5649eff91982adb4db37d0233765d49fe122d6158625904d9920b39b9ace5c11d602b8430467552899d3c30161ba21a3f0 SHA512 afbe8554c16df8305e781cf2dde3af1e7b25345dc1f5defc7723654479cc91d8f6fe9ddc3850fd487f77b241d40274edb2b7328ab011df93996264f14b98e6cd
diff --git a/net-analyzer/aimsniff/aimsniff-0.9d.ebuild b/net-analyzer/aimsniff/aimsniff-0.9d.ebuild
deleted file mode 100644
index e08fa33d31c5..000000000000
--- a/net-analyzer/aimsniff/aimsniff-0.9d.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils webapp eutils depend.apache
-
-WAS_VER="0.1.2b"
-
-DESCRIPTION="Utility for monitoring and archiving AOL Instant Messenger messages across a network"
-HOMEPAGE="https://sourceforge.net/projects/aimsniff/"
-SRC_URI="
- mirror://sourceforge/${PN}/${P}.tar.gz
- http? ( mirror://sourceforge/${PN}/was-${WAS_VER}.tar.gz )
-"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ppc x86"
-#SLOT empty due to webapp
-IUSE="samba mysql http"
-
-RDEPEND="
- dev-lang/perl[gdbm]
- dev-perl/Net-Pcap
- dev-perl/NetPacket
- dev-perl/Unicode-String
- dev-perl/Proc-Daemon
- dev-perl/Proc-Simple
- dev-perl/DBI
- dev-perl/Unix-Syslog
- mysql? ( virtual/mysql dev-perl/DBD-mysql )
- samba? ( net-fs/samba )
-"
-
-want_apache2 http
-
-pkg_setup() {
- depend.apache_pkg_setup http
-
- use http && webapp_pkg_setup
-}
-
-src_install() {
- use http && webapp_src_preinst
-
- newsbin aimSniff.pl aimsniff
- insinto /etc/${PN}
- doins aimsniff.config
- insinto /usr/share/doc/${PF}
- doins table.struct
- dodoc README ChangeLog
-
- if use http; then
- cp ../was-${WAS_VER}/docs/README README.WAS
- dodoc README.WAS
-
- rm -rf ../was-${WAS_VER}/docs
- mv ../was-${WAS_VER}/ "${D}"${MY_HTDOCSDIR}/was
-
- webapp_serverowned ${MY_HTDOCSDIR}/was
-
- # This file needs to be serverowned as the server won't be able to write to it if it were
- # webapp_configfile'ed.
- webapp_serverowned ${MY_HTDOCSDIR}/was/.config.php
-
- webapp_src_install
- fi
-
- newinitd "${FILESDIR}"/aimsniff.rc aimsniff
-}
-
-pkg_postinst() {
- if use mysql
- then
- echo
- elog "To create and enable the mysql database, please run: "
- elog "emerge --config =${PF}"
-
- if use http; then
- echo "To create and enable the mysql database, please run:
- emerge --config =${PF}" > apache-postinst
- webapp_postinst_txt en apache-postinst
- fi
- fi
-
- if use http; then
- elog
- elog "Go to http://${HOSTNAME}/was/admin.php to configure WAS."
-
- echo "Go to http://${HOSTNAME}/was/admin.php to configure WAS." > was-postinst
- webapp_postinst_txt en was-postinst
- fi
-}
-
-pkg_config() {
- echo
- einfo "Creating mysql database aimsniff using /usr/share/doc/${PF}/table.struct:"
- echo -n "Please enter your mysql root password: "
- read mysql_root
- /usr/bin/mysqladmin -p$mysql_root -u root create aimsniff
- /usr/bin/mysql -p$mysql_root -u root aimsniff < /usr/share/doc/${PF}/table.struct
- echo -n "Please enter your username that you want to connect to the database with: "
- read user
- echo -n "Please enter the password that you want to use for your database: "
- read password
- einfo "Granting permisions on database using 'GRANT ALL ON aimsniff.* TO $user IDENTIFIED BY '$password';'"
- echo "GRANT ALL ON aimsniff.* TO $user@localhost IDENTIFIED BY '$password';" | /usr/bin/mysql -p$mysql_root -u root aimsniff
- echo
-}
diff --git a/net-analyzer/aimsniff/files/aimsniff.rc b/net-analyzer/aimsniff/files/aimsniff.rc
deleted file mode 100644
index 276a21e730be..000000000000
--- a/net-analyzer/aimsniff/files/aimsniff.rc
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/sbin/openrc-run
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting asniff"
- start-stop-daemon -o --quiet --start --exec /usr/sbin/aimsniff -- \
- -C=/etc/aimsniff/aimsniff.config
- eend $?
-}
-
-stop() {
- ebegin "Stopping asniff"
- start-stop-daemon -o --stop -p /var/run/aimsniff_parent.pid -s QUIT
- eend $?
-}
diff --git a/net-analyzer/aimsniff/metadata.xml b/net-analyzer/aimsniff/metadata.xml
deleted file mode 100644
index 2c555e08cc4b..000000000000
--- a/net-analyzer/aimsniff/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription>aimsniff is a utility used for retrieving and storing AIM messages across a network.</longdescription>
- <use>
- <flag name="http">Install the WAS (Web AIM Sniff) frontend</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">aimsniff</remote-id>
- </upstream>
-</pkgmetadata>