summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-02-20 08:27:09 +0100
committerJeroen Roovers <jer@gentoo.org>2018-02-20 08:27:23 +0100
commitcab50b4f6fe2a058a89a8a0141dbceb74a68b2b0 (patch)
treea7de5e2acadc2bda814ba2c66ea2ce9a9f6e3ed8 /net-analyzer
parentdev-ruby/twitter: add ruby24 (diff)
downloadgentoo-cab50b4f6fe2a058a89a8a0141dbceb74a68b2b0.tar.gz
gentoo-cab50b4f6fe2a058a89a8a0141dbceb74a68b2b0.tar.bz2
gentoo-cab50b4f6fe2a058a89a8a0141dbceb74a68b2b0.zip
net-analyzer/sngrep: Initial commit (bug #534780).
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sngrep/Manifest1
-rw-r--r--net-analyzer/sngrep/files/sngrep-1.4.5-tinfo.patch13
-rw-r--r--net-analyzer/sngrep/metadata.xml12
-rw-r--r--net-analyzer/sngrep/sngrep-1.4.5.ebuild43
4 files changed, 69 insertions, 0 deletions
diff --git a/net-analyzer/sngrep/Manifest b/net-analyzer/sngrep/Manifest
new file mode 100644
index 000000000000..f6075c3f3853
--- /dev/null
+++ b/net-analyzer/sngrep/Manifest
@@ -0,0 +1 @@
+DIST sngrep-1.4.5.tar.gz 233379 BLAKE2B b2b080850ad9bc0ab961558781a3c8dd2b0d021d6d5763f6a0fbf56ad20581aeaed3b03804eecc4aa11ef2c8f796f742d990b33fb6d6929a735db7932785bc37 SHA512 428db158146fdf17e8276700a3c32e90d0d4b26b795f0c00eca047b048cf7b66fe20e3f9923823a5240018d1a941d1d32199bfe1bbb8622dc0d813fb0e7d6e73
diff --git a/net-analyzer/sngrep/files/sngrep-1.4.5-tinfo.patch b/net-analyzer/sngrep/files/sngrep-1.4.5-tinfo.patch
new file mode 100644
index 000000000000..f3829560264d
--- /dev/null
+++ b/net-analyzer/sngrep/files/sngrep-1.4.5-tinfo.patch
@@ -0,0 +1,13 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -98,6 +98,10 @@
+ ])
+ ])
+
++AC_SEARCH_LIBS([keyname], [tinfo], [], [
++ AC_MSG_ERROR([ You need to have ncurses panelw library installed to compile sngrep.])
++])
++
+ ####
+ #### GnuTLS Support
+ ####
diff --git a/net-analyzer/sngrep/metadata.xml b/net-analyzer/sngrep/metadata.xml
new file mode 100644
index 000000000000..eeb043ad62b3
--- /dev/null
+++ b/net-analyzer/sngrep/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+<email>netmon@gentoo.org</email>
+</maintainer>
+<use>
+<flag name='eep'>Enable EEP packet send/receive support</flag>
+<flag name='gnutls'>Use <pkg>net-libs/gnutls</pkg> to parse captured TLS packets</flag>
+<flag name='openssl'>Use <pkg>dev-libs/openssl</pkg> to parse captured TLS packets</flag>
+</use>
+</pkgmetadata>
diff --git a/net-analyzer/sngrep/sngrep-1.4.5.ebuild b/net-analyzer/sngrep/sngrep-1.4.5.ebuild
new file mode 100644
index 000000000000..f9c686aba4d0
--- /dev/null
+++ b/net-analyzer/sngrep/sngrep-1.4.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Ncurses SIP Messages flow viewer"
+HOMEPAGE="https://github.com/irontec/sngrep"
+SRC_URI="${HOMEPAGE}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="eep gnutls ipv6 openssl pcre unicode"
+REQUIRED_USE="
+ gnutls? ( !openssl )
+"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:*[unicode?]
+ openssl? ( dev-libs/openssl:* )
+ gnutls? ( net-libs/gnutls )
+"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.5-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable eep) \
+ $(use_enable ipv6) \
+ $(use_enable unicode) \
+ $(use_with gnutls) \
+ $(use_with openssl) \
+ $(use_with pcre)
+}