summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-07-24 21:09:54 +0200
committerJeroen Roovers <jer@gentoo.org>2017-07-24 21:10:15 +0200
commitcb2edecadc57bb2146a19e1d3e7036f1ebc53566 (patch)
tree4c6a1cf57fe2f0f5d96d5d5ba779d6e892185c9b /net-analyzer
parentnet-misc/youtube-dl: Old. (diff)
downloadgentoo-cb2edecadc57bb2146a19e1d3e7036f1ebc53566.tar.gz
gentoo-cb2edecadc57bb2146a19e1d3e7036f1ebc53566.tar.bz2
gentoo-cb2edecadc57bb2146a19e1d3e7036f1ebc53566.zip
net-analyzer/tcpdump: Version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpdump/Manifest1
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.9.1.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/net-analyzer/tcpdump/Manifest b/net-analyzer/tcpdump/Manifest
index 3c6cfe9dcf88..69b5f38afd70 100644
--- a/net-analyzer/tcpdump/Manifest
+++ b/net-analyzer/tcpdump/Manifest
@@ -1 +1,2 @@
DIST tcpdump-4.9.0.tar.gz 1260309 SHA256 eae98121cbb1c9adbedd9a777bf2eae9fa1c1c676424a54740311c8abcee5a5e SHA512 e98d73ae706d42e96b4069e196cf17af892eb97935664eebd08779b55b4da858bc1732d714efd16924f862aad0ba5550ceb2213c68414ed48907c46456c9fc82 WHIRLPOOL bd2284919bd3a2af166c6e05254e6fb7fa757b76f269d1a4951fe0ccfb6ad282a50f5670d3f8a38f6bffd1834bc809effd2e8575f9f0dd2fd7eaa4b4fdce5552
+DIST tcpdump-4.9.1.tar.gz 1192832 SHA256 4d1a69eab083d5df91effb805024abd4406e8a592e98558ed8722ef160c58119 SHA512 82ff20ece4c197f4b0142e45227310dc513facc9668c1423cb402eb2b62a18909a172c432ee6b20c012c172d47752ef65e2747f9d93d335073ea0ce3c007f5c9 WHIRLPOOL ed59af89e0c67477db3f10bd2d8c2b9b2dc2b3c7e3906abe37b0eba5024084e93afa98b39690c1c3af94cc6a0955023ee01ccfc5547a454dafe952957807295f
diff --git a/net-analyzer/tcpdump/tcpdump-4.9.1.ebuild b/net-analyzer/tcpdump/tcpdump-4.9.1.ebuild
new file mode 100644
index 000000000000..a3be92f321f9
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-4.9.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic toolchain-funcs user
+
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+HOMEPAGE="
+ http://www.tcpdump.org/
+ https://github.com/the-tcpdump-group/tcpdump
+"
+SRC_URI="
+ https://github.com/the-${PN}-group/${PN}/archive/${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+drop-root libressl smi ssl samba suid test"
+
+RDEPEND="
+ drop-root? ( sys-libs/libcap-ng )
+ net-libs/libpcap
+ smi? ( net-libs/libsmi )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6m:0 )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ drop-root? ( virtual/pkgconfig )
+ test? (
+ || ( app-arch/sharutils sys-freebsd/freebsd-ubin )
+ dev-lang/perl
+ )
+"
+S=${WORKDIR}/${PN}-${P}
+
+pkg_setup() {
+ if use drop-root || use suid; then
+ enewgroup tcpdump
+ enewuser tcpdump -1 -1 -1 tcpdump
+ fi
+}
+
+src_configure() {
+ if use drop-root; then
+ append-cppflags -DHAVE_CAP_NG_H
+ export LIBS=$( $(tc-getPKG_CONFIG) --libs libcap-ng )
+ fi
+
+ econf \
+ $(use_enable samba smb) \
+ $(use_with drop-root chroot '') \
+ $(use_with smi) \
+ $(use_with ssl crypto "${EPREFIX}/usr") \
+ $(usex drop-root "--with-user=tcpdump" "")
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]] || ! use drop-root; then
+ sed -i -e '/^\(espudp1\|eapon1\)/d;' tests/TESTLIST || die
+ emake check
+ else
+ ewarn "If you want to run the test suite, make sure you either"
+ ewarn "set FEATURES=userpriv or set USE=-drop-root"
+ fi
+}
+
+src_install() {
+ dosbin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc CHANGES CREDITS README.md
+
+ if use suid; then
+ fowners root:tcpdump /usr/sbin/tcpdump
+ fperms 4110 /usr/sbin/tcpdump
+ fi
+}
+
+pkg_preinst() {
+ if use drop-root || use suid; then
+ enewgroup tcpdump
+ enewuser tcpdump -1 -1 -1 tcpdump
+ fi
+}
+
+pkg_postinst() {
+ use suid && elog "To let normal users run tcpdump add them into tcpdump group."
+}