summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-01-15 12:54:49 -0600
committerJohn Helmert III <ajak@gentoo.org>2021-04-08 21:04:49 -0500
commitdaa4f8eaf521161105c604034448b8320eff1e80 (patch)
treee5e2c617310c866e772092f99f50d6cc7994d641 /net-analyzer
parentacct-user/snort: user for snort (diff)
downloadgentoo-daa4f8eaf521161105c604034448b8320eff1e80.tar.gz
gentoo-daa4f8eaf521161105c604034448b8320eff1e80.tar.bz2
gentoo-daa4f8eaf521161105c604034448b8320eff1e80.zip
net-analyzer/snort: add 2.9.17
Drop GCC 10 patch, unconditionally disable static, convert to GLEP 81. Bug: https://bugs.gentoo.org/765466 Closes: https://bugs.gentoo.org/781365 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/snort/Manifest1
-rw-r--r--net-analyzer/snort/snort-2.9.17.ebuild247
2 files changed, 248 insertions, 0 deletions
diff --git a/net-analyzer/snort/Manifest b/net-analyzer/snort/Manifest
index b4ad5b9977bc..5f00717d7601 100644
--- a/net-analyzer/snort/Manifest
+++ b/net-analyzer/snort/Manifest
@@ -1,2 +1,3 @@
DIST snort-2.9.15.1.tar.gz 6618999 BLAKE2B d9f661b036afa2130d406f8bcfa8d33fca482983e0e4785218e08899104c9069809b089631940109ee31e8d197783d994c58417d94f4b5282702e51466f828fa SHA512 9940f5bcdcf04823f9cb5c3f8efda72f98f6a47bce9f40399dec9ec41d23a386c7f7e44861d82368de31546123b920f9fc617197bbf9c5e750724bf8b9e19590
DIST snort-2.9.16.tar.gz 6948498 BLAKE2B b089f1caef44cd5243c38eba44e7449b1111b397e42eb1722f64530206532edb413003e6af06d18bc6051ef1ce8cbcf42955d823a56abe061081e99c6492dea7 SHA512 7e4e772d351890cb6ad6db4210e1f302fbb600b3b25182800ffd7e73061a044c2cf6fa927e542a1d20cea4fa3eed522f022b394a9286ada7694309d0c8c3bb75
+DIST snort-2.9.17.tar.gz 6983018 BLAKE2B 8a6d5f4311e304b141f705fdcd3f570e88540dc5ce5882887b6fa52ea16e41daac384012badcbbc087693ee631e30477b8af2a6c49efa8230c71b80937597355 SHA512 c1a69e697298b4e85b8b8898e29077f5e74d8e2a8e42c2164a5597b3739204d856a74f30bc7c30b1907ec7b3bd3c6c6d798ead890656386b0c2a2da2c201d006
diff --git a/net-analyzer/snort/snort-2.9.17.ebuild b/net-analyzer/snort/snort-2.9.17.ebuild
new file mode 100644
index 000000000000..760efe961a4f
--- /dev/null
+++ b/net-analyzer/snort/snort-2.9.17.ebuild
@@ -0,0 +1,247 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( luajit )
+
+inherit autotools lua-single systemd tmpfiles multilib
+
+DESCRIPTION="The de facto standard for intrusion detection/prevention"
+HOMEPAGE="https://www.snort.org"
+SRC_URI="https://www.snort.org/downloads/archive/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+active-response control-socket debug file-inspect +flexresp3 +gre
+high-availability inline-init-failopen large-pcap-64bit +libtirpc
+linux-smp-stats +non-ether-decoders open-appid +perfprofiling +ppm +react
+reload-error-restart selinux shared-rep side-channel sourcefire +threads"
+
+DEPEND="acct-user/snort
+ acct-group/snort
+ dev-libs/libdnet
+ >=dev-libs/libpcre-8.33
+ net-libs/libnsl:0=
+ >=net-libs/libpcap-1.3.0
+ sys-libs/zlib
+ !libtirpc? ( sys-libs/glibc[rpc(-)] )
+ libtirpc? ( net-libs/libtirpc )
+ open-appid? ( ${LUA_DEPS} )"
+BDEPEND=">=net-libs/daq-2.0.2"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-snort )"
+
+REQUIRED_USE="!kernel_linux? ( !shared-rep )
+ open-appid? ( ${LUA_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.9.8.3-no-implicit.patch"
+ "${FILESDIR}/${PN}-2.9.8.3-rpc.patch"
+ "${FILESDIR}/${PN}-2.9.12-snort.pc.patch"
+)
+
+pkg_setup() {
+ use open-appid && lua-single_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+
+ # USE=debug exposes a macro whose name apparently wasn't changed
+ sed -i -e 's/BEFORE_SRV_FAIL/BEFORE_SERVICE_FAIL/' \
+ src/dynamic-preprocessors/appid/appInfoTable.c || die
+
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gre) \
+ $(use_enable control-socket) \
+ $(use_enable file-inspect) \
+ $(use_enable high-availability ha) \
+ $(use_enable non-ether-decoders) \
+ $(use_enable shared-rep) \
+ $(use_enable side-channel) \
+ $(use_enable sourcefire) \
+ $(use_enable ppm) \
+ $(use_enable perfprofiling) \
+ $(use_enable linux-smp-stats) \
+ $(use_enable inline-init-failopen) \
+ $(use_enable open-appid) \
+ $(use_enable threads pthread) \
+ $(use_enable debug) \
+ $(use_enable debug debug-msgs) \
+ $(use_enable debug corefiles) \
+ $(use_enable !debug dlclose) \
+ $(use_enable active-response) \
+ $(use_enable reload-error-restart) \
+ $(use_enable react) \
+ $(use_enable flexresp3) \
+ $(use_enable large-pcap-64bit large-pcap) \
+ $(use_with libtirpc) \
+ --enable-mpls \
+ --enable-normalizer \
+ --enable-reload \
+ --enable-targetbased \
+ --disable-build-dynamic-examples \
+ --disable-profile \
+ --disable-ppm-test \
+ --disable-intel-soft-cpm \
+ --disable-static-daq \
+ --disable-static \
+ --disable-so-with-static-lib
+}
+
+src_install() {
+ default
+
+ keepdir /var/log/snort \
+ /etc/snort/rules \
+ /etc/snort/so_rules \
+ /usr/$(get_libdir)/snort_dynamicrules
+
+ # config.log and build.log are needed by Sourcefire
+ # to trouble shoot build problems and bug reports so we are
+ # perserving them incase the user needs upstream support.
+ dodoc RELEASE.NOTES ChangeLog \
+ doc/* \
+ tools/u2boat/README.u2boat
+
+ insinto /etc/snort
+ doins etc/attribute_table.dtd \
+ etc/classification.config \
+ etc/gen-msg.map \
+ etc/reference.config \
+ etc/threshold.conf \
+ etc/unicode.map
+
+ # We use snort.conf.distrib because the config file is complicated
+ # and the one shipped with snort can change drastically between versions.
+ # Users should migrate setting by hand and not with etc-update.
+ newins etc/snort.conf snort.conf.distrib
+
+ # config.log and build.log are needed by Sourcefire
+ # to troubleshoot build problems and bug reports so we are
+ # preserving them incase the user needs upstream support.
+ if [ -f "${WORKDIR}/${PF}/config.log" ]; then
+ dodoc "${WORKDIR}/${PF}/config.log"
+ fi
+ if [ -f "${T}/build.log" ]; then
+ dodoc "${T}/build.log"
+ fi
+
+ insinto /etc/snort/preproc_rules
+ doins preproc_rules/decoder.rules \
+ preproc_rules/preprocessor.rules \
+ preproc_rules/sensitive-data.rules
+
+ fowners -R snort:snort \
+ /var/log/snort \
+ /etc/snort
+
+ newinitd "${FILESDIR}/snort.rc12" snort
+ newconfd "${FILESDIR}/snort.confd.2" snort
+ systemd_newunit "${FILESDIR}/snort_at.service" "snort@.service"
+
+ newtmpfiles "${FILESDIR}"/snort.tmpfiles snort.conf
+
+ # Sourcefire uses Makefiles to install docs causing Bug #297190.
+ # This removes the unwanted doc directory and rogue Makefiles.
+ rm -rf "${ED}"/usr/share/doc/snort || die "Failed to remove SF doc directories"
+ rm "${ED}"/usr/share/doc/"${PF}"/Makefile* || die "Failed to remove doc make files"
+
+ # Remove unneeded .la files (Bug #382863)
+ find "${ED}" -name '*.la' -type f -delete || die
+
+ # Set the correct lib path for dynamicengine, dynamicpreprocessor, and dynamicdetection
+ sed -i -e 's|/usr/local/lib|/usr/'$(get_libdir)'|g' \
+ "${ED}/etc/snort/snort.conf.distrib" || die
+
+ # Set the correct rule location in the config
+ sed -i -e 's|RULE_PATH ../rules|RULE_PATH /etc/snort/rules|g' \
+ "${ED}/etc/snort/snort.conf.distrib" || die
+
+ # Set the correct preprocessor/decoder rule location in the config
+ sed -i -e 's|PREPROC_RULE_PATH ../preproc_rules|PREPROC_RULE_PATH /etc/snort/preproc_rules|g' \
+ "${ED}/etc/snort/snort.conf.distrib" || die
+
+ # Enable the preprocessor/decoder rules
+ sed -i -e 's|^# include $PREPROC_RULE_PATH|include $PREPROC_RULE_PATH|g' \
+ "${ED}/etc/snort/snort.conf.distrib" || die
+
+ sed -i -e 's|^# dynamicdetection directory|dynamicdetection directory|g' \
+ "${ED}/etc/snort/snort.conf.distrib" || die
+
+ # Just some clean up of trailing /'s in the config
+ sed -i -e 's|snort_dynamicpreprocessor/$|snort_dynamicpreprocessor|g' \
+ "${ED}/etc/snort/snort.conf.distrib" || die
+
+ # Make it clear in the config where these are...
+ sed -i -e 's|^include classification.config|include /etc/snort/classification.config|g' \
+ "${ED}/etc/snort/snort.conf.distrib" || die
+
+ sed -i -e 's|^include reference.config|include /etc/snort/reference.config|g' \
+ "${ED}/etc/snort/snort.conf.distrib" || die
+
+ # Disable all rule files by default.
+ sed -i -e 's|^include $RULE_PATH|# include $RULE_PATH|g' \
+ "${ED%}/etc/snort/snort.conf.distrib" || die
+
+ # Set the configured DAQ to afpacket
+ sed -i -e 's|^# config daq: <type>|config daq: afpacket|g' \
+ "${ED%}/etc/snort/snort.conf.distrib" || die
+
+ # Set the location of the DAQ modules
+ sed -i -e 's|^# config daq_dir: <dir>|config daq_dir: /usr/'$(get_libdir)'/daq|g' \
+ "${ED%}/etc/snort/snort.conf.distrib" || die
+
+ # Set the DAQ mode to passive
+ sed -i -e 's|^# config daq_mode: <mode>|config daq_mode: passive|g' \
+ "${ED%}/etc/snort/snort.conf.distrib" || die
+
+ # Set snort to run as snort:snort
+ sed -i -e 's|^# config set_gid:|config set_gid: snort|g' \
+ "${ED}/etc/snort/snort.conf.distrib" || die
+ sed -i -e 's|^# config set_uid:|config set_uid: snort|g' \
+ "${ED}/etc/snort/snort.conf.distrib" || die
+
+ # Set the default log dir
+ sed -i -e 's|^# config logdir:|config logdir: /var/log/snort/|g' \
+ "${ED}/etc/snort/snort.conf.distrib" || die
+
+ # Set the correct so_rule location in the config
+ sed -i -e 's|SO_RULE_PATH ../so_rules|SO_RULE_PATH /etc/snort/so_rules|g' \
+ "${ED}/etc/snort/snort.conf.distrib" || die
+}
+
+pkg_postinst() {
+ tmpfiles_process snort.conf
+
+ einfo "There have been a number of improvements and new features"
+ einfo "added to ${P}. Please review the RELEASE.NOTES and"
+ einfo "ChangLog located in /usr/share/doc/${PF}."
+ einfo
+ elog "The Sourcefire Vulnerability Research Team (VRT) recommends that"
+ elog "users migrate their snort.conf customizations to the latest config"
+ elog "file released by the VRT. You can find the latest version of the"
+ elog "Snort config file in /etc/snort/snort.conf.distrib."
+ elog
+ elog "!! It is important that you migrate to this new snort.conf file !!"
+ elog
+ elog "This version of the ebuild includes an updated init.d file and"
+ elog "conf.d file that rely on options found in the latest Snort"
+ elog "config file provided by the VRT."
+
+ if use debug; then
+ elog "You have the 'debug' USE flag enabled. If this has been done to"
+ elog "troubleshoot an issue by producing a core dump or a back trace,"
+ elog "then you need to also ensure the FEATURES variable in make.conf"
+ elog "contains the 'nostrip' option."
+ fi
+}