summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-09 00:10:56 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-09 00:10:56 -0400
commitdc84e28155f4fc7af82b0a79b55c48a4fa0d65c2 (patch)
treea268ba065684a84be420eb0daff438f34b67feca /net-analyzer
parentmail-filter/pypolicyd-spf: remove old v1.1 and v1.3.1. (diff)
downloadgentoo-dc84e28155f4fc7af82b0a79b55c48a4fa0d65c2.tar.gz
gentoo-dc84e28155f4fc7af82b0a79b55c48a4fa0d65c2.tar.bz2
gentoo-dc84e28155f4fc7af82b0a79b55c48a4fa0d65c2.zip
net-analyzer/monitoring-plugins: remove old v2.1.1.
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/monitoring-plugins/Manifest1
-rw-r--r--net-analyzer/monitoring-plugins/monitoring-plugins-2.1.1.ebuild96
2 files changed, 0 insertions, 97 deletions
diff --git a/net-analyzer/monitoring-plugins/Manifest b/net-analyzer/monitoring-plugins/Manifest
index 7be3afa58b69..46c48c39d240 100644
--- a/net-analyzer/monitoring-plugins/Manifest
+++ b/net-analyzer/monitoring-plugins/Manifest
@@ -1,2 +1 @@
-DIST monitoring-plugins-2.1.1.tar.gz 2612331 SHA256 44dbace8033eafb716cc501bfef26ca9071ae3d0329b2c118bd0230fd98dd1d3 SHA512 0b5d0aefe4aab938287509fcd20c0bb5a1e79848ef85127bbf33d365e62fd9442d230dc4ac605e5d815b68827550485a2b01973b7527d7e611b0821199ed60aa WHIRLPOOL 8355cec22b8ea540a149f65ea74d16890475b2799db564109ea790fe6d3c2dc9b42af2103594048ea9e6ee3de4041fcc8c45805e53f23de5b8b56e89b77b8ba8
DIST monitoring-plugins-2.1.2.tar.gz 2613060 SHA256 76c6b58f0867ab7b6c8c86c7e94fcce7183618f6daab63488990d0355f5600aa SHA512 845eb7636691aa5402119384c3d4256969e959fbc29ef5257c24fc4c21536cad3dade30747f36c9ad998cb37df0f325df66ea679d3d5b96c2993b59a9a325fed WHIRLPOOL aea22e1a3d3c7622b4645118cf8b5d499882bd30b6af8bdd81287fb99fe42bff7f906b54fda411ac2c33ff6e42872a6ea6af4dcd7611bdc95d308c0fcd954e43
diff --git a/net-analyzer/monitoring-plugins/monitoring-plugins-2.1.1.ebuild b/net-analyzer/monitoring-plugins/monitoring-plugins-2.1.1.ebuild
deleted file mode 100644
index 3a69daeca9c2..000000000000
--- a/net-analyzer/monitoring-plugins/monitoring-plugins-2.1.1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils multilib user
-
-DESCRIPTION="50+ standard plugins for Icinga, Naemon, Nagios, Shinken, Sensu"
-HOMEPAGE="https://www.monitoring-plugins.org/"
-SRC_URI="https://www.monitoring-plugins.org/download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="gnutls ipv6 ldap mysql dns fping game postgres samba snmp ssh +ssl"
-
-# Most of the plugins use automagic dependencies, i.e. the plugin will
-# get built if the binary it uses is installed. For example, check_snmp
-# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
-# installed. End result: most of our runtime dependencies are required
-# at build time as well.
-#
-# REAL_DEPEND contains the dependencies that are actually needed to
-# build. DEPEND contains those plus the automagic dependencies.
-#
-REAL_DEPEND="dev-lang/perl
- ldap? ( net-nds/openldap )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )
- ssl? (
- !gnutls? ( dev-libs/openssl )
- gnutls? ( net-libs/gnutls )
- )"
-
-DEPEND="${REAL_DEPEND}
- dns? ( net-dns/bind-tools )
- game? ( games-util/qstat )
- fping? ( net-analyzer/fping )
- samba? ( net-fs/samba )
- ssh? ( net-misc/openssh )
- snmp? ( dev-perl/Net-SNMP
- net-analyzer/net-snmp[-minimal] )"
-
-# Basically everything collides with nagios-plugins.
-RDEPEND="${DEPEND}
- !net-analyzer/nagios-plugins"
-
-# At least one test is interactive.
-RESTRICT="test"
-
-src_configure() {
- # Use an array to prevent econf from mangling the ping args.
- local myconf=()
-
- if use ssl; then
- myconf+=( $(use_with !gnutls openssl /usr)
- $(use_with gnutls gnutls /usr) )
- else
- myconf+=( --without-openssl )
- myconf+=( --without-gnutls )
- fi
-
- # The autodetection for these two commands can hang if localhost is
- # down or ICMP traffic is filtered. Bug #468296.
- myconf+=( --with-ping-command="/bin/ping -n -U -w %d -c %d %s" )
-
- if use ipv6; then
- myconf+=( --with-ping6-command="/bin/ping6 -n -U -w %d -c %d %s" )
- fi
-
- econf \
- $(use_with mysql) \
- $(use_with ipv6) \
- $(use_with ldap) \
- $(use_with postgres pgsql /usr) \
- "${myconf[@]}" \
- --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
- --sysconfdir="/etc/nagios"
-}
-
-DOCS=( ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ \
- NEWS README REQUIREMENTS SUPPORT THANKS )
-
-pkg_preinst() {
- enewgroup nagios
- enewuser nagios -1 /bin/bash /var/nagios/home nagios
-}
-
-pkg_postinst() {
- elog "This ebuild has a number of USE flags that determine what you"
- elog "are able to monitor. Depending on what you want to monitor, some"
- elog "or all of these USE flags need to be set."
- elog
- elog "The plugins are installed in ${ROOT}usr/$(get_libdir)/nagios/plugins"
-}