summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 21:45:16 +0000
committerSam James <sam@gentoo.org>2021-03-16 21:45:16 +0000
commite9bf9cb3caad389d0908af434eb09b268907c18b (patch)
tree020fdb461d1bfa8afaa21fb003e141d265ae462a /net-analyzer
parentapp-shells/pdsh: add github upstream metadata (diff)
downloadgentoo-e9bf9cb3caad389d0908af434eb09b268907c18b.tar.gz
gentoo-e9bf9cb3caad389d0908af434eb09b268907c18b.tar.bz2
gentoo-e9bf9cb3caad389d0908af434eb09b268907c18b.zip
net-analyzer/snort: forcefully remove .la files
Fixes build with slibtool where they don't exist in the first place. Closes: https://bugs.gentoo.org/775179 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/snort/snort-2.9.15.1.ebuild6
-rw-r--r--net-analyzer/snort/snort-2.9.16-r100.ebuild6
-rw-r--r--net-analyzer/snort/snort-2.9.16.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/net-analyzer/snort/snort-2.9.15.1.ebuild b/net-analyzer/snort/snort-2.9.15.1.ebuild
index 21bdbd512480..440d87d8359a 100644
--- a/net-analyzer/snort/snort-2.9.15.1.ebuild
+++ b/net-analyzer/snort/snort-2.9.15.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -154,8 +154,8 @@ src_install() {
rm "${ED}"/usr/share/doc/"${PF}"/Makefile* || die "Failed to remove doc make files"
# Remove unneeded .la files (Bug #382863)
- rm "${ED}"/usr/$(get_libdir)/snort_dynamicengine/libsf_engine.la || die
- rm "${ED}"/usr/$(get_libdir)/snort_dynamicpreprocessor/libsf_*_preproc.la || die "Failed to remove libsf_?_preproc.la"
+ rm -f "${ED}"/usr/$(get_libdir)/snort_dynamicengine/libsf_engine.la || die
+ rm -f "${ED}"/usr/$(get_libdir)/snort_dynamicpreprocessor/libsf_*_preproc.la || die "Failed to remove libsf_?_preproc.la"
# Set the correct lib path for dynamicengine, dynamicpreprocessor, and dynamicdetection
sed -i -e 's|/usr/local/lib|/usr/'$(get_libdir)'|g' \
diff --git a/net-analyzer/snort/snort-2.9.16-r100.ebuild b/net-analyzer/snort/snort-2.9.16-r100.ebuild
index c3363729e9af..66b2b845e872 100644
--- a/net-analyzer/snort/snort-2.9.16-r100.ebuild
+++ b/net-analyzer/snort/snort-2.9.16-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -159,8 +159,8 @@ src_install() {
rm "${ED}"/usr/share/doc/"${PF}"/Makefile* || die "Failed to remove doc make files"
# Remove unneeded .la files (Bug #382863)
- rm "${ED}"/usr/$(get_libdir)/snort_dynamicengine/libsf_engine.la || die
- rm "${ED}"/usr/$(get_libdir)/snort_dynamicpreprocessor/libsf_*_preproc.la || die "Failed to remove libsf_?_preproc.la"
+ rm -f "${ED}"/usr/$(get_libdir)/snort_dynamicengine/libsf_engine.la || die
+ rm -f "${ED}"/usr/$(get_libdir)/snort_dynamicpreprocessor/libsf_*_preproc.la || die "Failed to remove libsf_?_preproc.la"
# Set the correct lib path for dynamicengine, dynamicpreprocessor, and dynamicdetection
sed -i -e 's|/usr/local/lib|/usr/'$(get_libdir)'|g' \
diff --git a/net-analyzer/snort/snort-2.9.16.ebuild b/net-analyzer/snort/snort-2.9.16.ebuild
index 6e7835a53107..4a3f0392b5c1 100644
--- a/net-analyzer/snort/snort-2.9.16.ebuild
+++ b/net-analyzer/snort/snort-2.9.16.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -154,8 +154,8 @@ src_install() {
rm "${ED}"/usr/share/doc/"${PF}"/Makefile* || die "Failed to remove doc make files"
# Remove unneeded .la files (Bug #382863)
- rm "${ED}"/usr/$(get_libdir)/snort_dynamicengine/libsf_engine.la || die
- rm "${ED}"/usr/$(get_libdir)/snort_dynamicpreprocessor/libsf_*_preproc.la || die "Failed to remove libsf_?_preproc.la"
+ rm -f "${ED}"/usr/$(get_libdir)/snort_dynamicengine/libsf_engine.la || die
+ rm -f "${ED}"/usr/$(get_libdir)/snort_dynamicpreprocessor/libsf_*_preproc.la || die "Failed to remove libsf_?_preproc.la"
# Set the correct lib path for dynamicengine, dynamicpreprocessor, and dynamicdetection
sed -i -e 's|/usr/local/lib|/usr/'$(get_libdir)'|g' \