summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-02-16 10:58:55 -0500
committerMichael Orlitzky <mjo@gentoo.org>2019-02-16 11:01:09 -0500
commitec0cf769285f14f04060a9d0ce5ebf3a58aef255 (patch)
tree9d34d40133c5a13457647c7d86c4d4d76499b854 /net-analyzer
parentmedia-plugins/grilo-plugins: bump to 0.3.8 (diff)
downloadgentoo-ec0cf769285f14f04060a9d0ce5ebf3a58aef255.tar.gz
gentoo-ec0cf769285f14f04060a9d0ce5ebf3a58aef255.tar.bz2
gentoo-ec0cf769285f14f04060a9d0ce5ebf3a58aef255.zip
net-analyzer/nagios-plugins: remove old "unused" ebuilds.
Signed-off-by: Michael Orlitzky <mjo@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins/Manifest1
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-2.0.3-r2.ebuild97
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-2.2.1-r2.ebuild118
3 files changed, 0 insertions, 216 deletions
diff --git a/net-analyzer/nagios-plugins/Manifest b/net-analyzer/nagios-plugins/Manifest
index 5495ce352bca..325cb951dd79 100644
--- a/net-analyzer/nagios-plugins/Manifest
+++ b/net-analyzer/nagios-plugins/Manifest
@@ -1,2 +1 @@
-DIST nagios-plugins-2.0.3.tar.gz 2659772 BLAKE2B d4deccf04458daccde5fbe7e6c659282d36fec69096e6b1b8487455db0089f7a5073ce14ef6a74f82869de08ad740b0d3b617d691c85b8895e475302152ca33c SHA512 2753e6f3fc7433a5583fee01e63a65b9ea74155964f2b6e6bf3458e56cb29ea5dbd020f83816044a717b66d6548d203b3a082fba0faedcd629c7a8457bc19b36
DIST nagios-plugins-2.2.1.tar.gz 2728818 BLAKE2B ea89862935491d9c31403a36712d39557fa8e90dc2306e027531e974933cd13cc6b55ebfdd7dfc7541d6458741aaf57714df57fdddc92049001a59f0ffb6413a SHA512 6ffe313a56a305b382f62abc0f0958d7078f9050e1340f30721d6e6f71944b57b1650e90e6835c35dd7c9f3f4b4cee9f235b8382b0811db30b3729daaafc9bc3
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-2.0.3-r2.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-2.0.3-r2.ebuild
deleted file mode 100644
index e50223884561..000000000000
--- a/net-analyzer/nagios-plugins/nagios-plugins-2.0.3-r2.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils multilib user
-
-DESCRIPTION="Official set of plugins for Nagios"
-HOMEPAGE="http://nagios-plugins.org/"
-SRC_URI="http://nagios-plugins.org/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ~arm64 hppa ppc ppc64 sparc x86"
-IUSE="ipv6 ldap mysql nagios-dns nagios-ping nagios-game postgres samba snmp ssh +ssl"
-
-# Most of the plugins use automagic dependencies, i.e. the plugin will
-# get built if the binary it uses is installed. For example, check_snmp
-# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
-# installed. End result: most of our runtime dependencies are required
-# at build time as well.
-#
-# REAL_DEPEND contains the dependencies that are actually needed to
-# build. DEPEND contains those plus the automagic dependencies.
-#
-REAL_DEPEND="dev-lang/perl
- ldap? ( net-nds/openldap )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql:* )
- ssl? ( dev-libs/openssl:0 )"
-
-DEPEND="${REAL_DEPEND}
- nagios-dns? ( net-dns/bind-tools )
- nagios-game? ( games-util/qstat )
- nagios-ping? ( net-analyzer/fping )
- samba? ( net-fs/samba )
- ssh? ( net-misc/openssh )
- snmp? ( dev-perl/Net-SNMP
- net-analyzer/net-snmp[-minimal] )"
-
-# Basically everything collides with nagios-plugins.
-RDEPEND="${DEPEND}
- !net-analyzer/monitoring-plugins"
-
-# At least one test is interactive.
-RESTRICT="test"
-
-src_prepare() {
- # Fix the path to our perl interpreter
- sed -i -e "1s:/usr/local/bin/perl:/usr/bin/perl:" \
- "${S}"/plugins-scripts/*.pl || die
-}
-
-src_configure() {
- # Use an array to prevent econf from mangling the ping args.
- local myconf=()
-
- if use ssl; then
- myconf+=( $(use_with ssl openssl /usr) )
- else
- myconf+=( --without-openssl )
- myconf+=( --without-gnutls )
- fi
-
- # The autodetection for these two commands can hang if localhost is
- # down or ICMP traffic is filtered. Bug #468296.
- myconf+=( --with-ping-command="/bin/ping -n -U -w %d -c %d %s" )
-
- if use ipv6; then
- myconf+=( --with-ping6-command="/bin/ping6 -n -U -w %d -c %d %s" )
- fi
-
- econf \
- $(use_with mysql) \
- $(use_with ipv6) \
- $(use_with ldap) \
- $(use_with postgres pgsql /usr) \
- "${myconf[@]}" \
- --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
- --sysconfdir="/etc/nagios"
-}
-
-DOCS=( ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ \
- NEWS README REQUIREMENTS SUPPORT THANKS )
-
-pkg_preinst() {
- enewgroup nagios
- enewuser nagios -1 /bin/bash /var/nagios/home nagios
-}
-
-pkg_postinst() {
- elog "This ebuild has a number of USE flags that determine what you"
- elog "are able to monitor. Depending on what you want to monitor, some"
- elog "or all of these USE flags need to be set."
- elog
- elog "The plugins are installed in ${ROOT}usr/$(get_libdir)/nagios/plugins"
-}
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-2.2.1-r2.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-2.2.1-r2.ebuild
deleted file mode 100644
index 70bc775d0c45..000000000000
--- a/net-analyzer/nagios-plugins/nagios-plugins-2.2.1-r2.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit user
-
-DESCRIPTION="Official plugins for Nagios"
-HOMEPAGE="http://nagios-plugins.org/"
-SRC_URI="http://nagios-plugins.org/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ppc ppc64 sparc x86"
-IUSE="ipv6 ldap libressl mysql nagios-dns nagios-ping nagios-game postgres radius samba selinux snmp ssh +ssl"
-
-# Most of the plugins use automagic dependencies, i.e. the plugin will
-# get built if the binary it uses is installed. For example, check_snmp
-# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
-# installed. End result: most of our runtime dependencies are required
-# at build time as well.
-#
-# REAL_DEPEND contains the dependencies that are actually needed to
-# build. DEPEND contains those plus the automagic dependencies.
-#
-REAL_DEPEND="dev-lang/perl
- ldap? ( net-nds/openldap )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql:* )
- ssl? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- )
- radius? ( net-dialup/freeradius-client )"
-
-DEPEND="${REAL_DEPEND}
- nagios-dns? ( net-dns/bind-tools )
- nagios-game? ( games-util/qstat )
- nagios-ping? ( net-analyzer/fping )
- samba? ( net-fs/samba )
- ssh? ( net-misc/openssh )
- snmp? ( dev-perl/Net-SNMP
- net-analyzer/net-snmp[-minimal] )"
-
-# Basically everything collides with nagios-plugins.
-RDEPEND="${DEPEND}
- !net-analyzer/monitoring-plugins
- selinux? ( sec-policy/selinux-nagios )"
-
-# At least one test is interactive.
-RESTRICT="test"
-
-DOCS=(
- ACKNOWLEDGEMENTS
- AUTHORS
- CODING
- ChangeLog
- FAQ
- NEWS
- README
- REQUIREMENTS
- SUPPORT
- THANKS
-)
-
-PATCHES=( "${FILESDIR}/define-own-mysql-port-constant.patch" )
-
-src_prepare() {
- default
-
- # Fix the path to our perl interpreter
- sed -i -e "1s:/usr/local/bin/perl:/usr/bin/perl:" \
- "${S}"/plugins-scripts/*.pl \
- || die 'failed to fix perl interpreter path'
-}
-
-src_configure() {
- # Use an array to prevent econf from mangling the ping args.
- local myconf=()
-
- if use ssl; then
- myconf+=( $(use_with ssl openssl /usr) )
- else
- myconf+=( --without-openssl )
- myconf+=( --without-gnutls )
- fi
-
- # The autodetection for these two commands can hang if localhost is
- # down or ICMP traffic is filtered. Bug #468296.
- myconf+=( --with-ping-command="/bin/ping -n -U -w %d -c %d %s" )
-
- if use ipv6; then
- myconf+=( --with-ping6-command="/bin/ping6 -n -U -w %d -c %d %s" )
- fi
-
- econf \
- $(use_with mysql) \
- $(use_with ipv6) \
- $(use_with ldap) \
- $(use_with postgres pgsql /usr) \
- $(use_with radius) \
- "${myconf[@]}" \
- --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
- --sysconfdir="/etc/nagios"
-}
-
-pkg_preinst() {
- enewgroup nagios
- enewuser nagios -1 /bin/bash /var/nagios/home nagios
-}
-
-pkg_postinst() {
- elog "This ebuild has a number of USE flags that determine what you"
- elog "are able to monitor. Depending on what you want to monitor, some"
- elog "or all of these USE flags need to be set."
- elog
- elog "The plugins are installed in ${ROOT}usr/$(get_libdir)/nagios/plugins"
-}