summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-01 02:25:29 +0000
committerSam James <sam@gentoo.org>2023-01-01 02:25:29 +0000
commitedb2ec3822ac62f0061a022d5bc993314c3a912e (patch)
treea5f48507ff860b2d0c1b746ae9b18e0f3872b778 /net-analyzer
parentnet-analyzer/traceroute: add 2.1.1 (diff)
downloadgentoo-edb2ec3822ac62f0061a022d5bc993314c3a912e.tar.gz
gentoo-edb2ec3822ac62f0061a022d5bc993314c3a912e.tar.bz2
gentoo-edb2ec3822ac62f0061a022d5bc993314c3a912e.zip
net-analyzer/tcpdump: add 4.99.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpdump/Manifest2
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.99.2.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/net-analyzer/tcpdump/Manifest b/net-analyzer/tcpdump/Manifest
index 713c659ac15d..7caa0af89c5c 100644
--- a/net-analyzer/tcpdump/Manifest
+++ b/net-analyzer/tcpdump/Manifest
@@ -1,2 +1,4 @@
DIST tcpdump-4.99.1-upstream.tar.gz 2014324 BLAKE2B 0a10fe68afdfe80d3e7e661352fcaf1c47702df27fbed959f52fb0ec81543a1d4ce6b0de16a8b081de48dd43e09a13f5e1f0fb11d7590f92cbff29dc511bea12 SHA512 53d31355e1a6ef5a65bb3bf72454169fc80adf973a327a5768840e6ccf0550fbeb3c8a41f959635076d871df0619680321910a3a97879607f481cdaa8b7ceda7
DIST tcpdump-4.99.1-upstream.tar.gz.sig 442 BLAKE2B 9a80b1796ef777bd06d0b8953fe1ff446431d0ff1dffcd58e29a0b771f6734f70f3f0da7c36a1eaa1b6e57719d79c601872a84b7734208a7e8951cad9aca86ee SHA512 b438643701efbbb5579d9d51ed48756a47dd644e0acb10b0edff6d04f3ae4cea6528b40820a656407b73f983b2a634e0165a6c8c0fca3b557394a14e2f2384ab
+DIST tcpdump-4.99.2.tar.gz 1897480 BLAKE2B be13fbf493478270c8ebc034a3c1467907a008ce2ed9632a87b7d7b9104b9fda248cd535da7313a1c3d57ca21f324c25593812590b96ec334c474d1ce06f3fd5 SHA512 7986e7517441872d4461da23dc546c01e23449108974458a4e5e493db6f066f9e7da801623a6c43cfa2079ac3d409f813d1ffde2ecc12b6dba661dae0693b735
+DIST tcpdump-4.99.2.tar.gz.sig 442 BLAKE2B 011c93803a1c339f9ce46dedb8e3420d77c5362575061c9b852647d8e8de6936079150240b444f660a84b9e45337960b8878e7c4de1f4e6ad2fff16225811d24 SHA512 33704e9b2ece65ca8a1fbf8234088e561f132a561ac859da32c7fb4d4caaeabd9a4b50ac8f939e48c18e672dade9393c7e56bc838ec8ac9828be5360e99e5692
diff --git a/net-analyzer/tcpdump/tcpdump-4.99.2.ebuild b/net-analyzer/tcpdump/tcpdump-4.99.2.ebuild
new file mode 100644
index 000000000000..90c41439b38b
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-4.99.2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A tool for network monitoring and data acquisition"
+HOMEPAGE="https://www.tcpdump.org/ https://github.com/the-tcpdump-group/tcpdump"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/the-tcpdump-group/tcpdump"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/tcpdump.asc
+ inherit verify-sig
+
+ SRC_URI="https://www.tcpdump.org/release/${P}.tar.gz"
+ SRC_URI+=" verify-sig? ( https://www.tcpdump.org/release/${P}.tar.gz.sig )"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="+drop-root +smi +ssl +samba suid test"
+REQUIRED_USE="test? ( samba )"
+
+# Assorted failures: bug #768498
+RESTRICT="test"
+
+RDEPEND="
+ >=net-libs/libpcap-1.10.1
+ drop-root? (
+ acct-group/pcap
+ acct-user/pcap
+ sys-libs/libcap-ng
+ )
+ smi? ( net-libs/libsmi )
+ ssl? (
+ >=dev-libs/openssl-0.9.6m:0=
+ )
+ suid? (
+ acct-group/pcap
+ acct-user/pcap
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-lang/perl
+ )
+"
+BDEPEND="drop-root? ( virtual/pkgconfig )"
+
+if [[ ${PV} != *9999* ]] ; then
+ BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-tcpdump )"
+fi
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-libdir.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable samba smb) \
+ $(use_with drop-root cap-ng) \
+ $(use_with drop-root chroot '') \
+ $(use_with smi) \
+ $(use_with ssl crypto "${ESYSROOT}/usr") \
+ $(usex drop-root "--with-user=pcap" "")
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]] || ! use drop-root ; then
+ emake check
+ else
+ ewarn "If you want to run the test suite, make sure you either"
+ ewarn "set FEATURES=userpriv or set USE=-drop-root"
+ fi
+}
+
+src_install() {
+ dosbin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc CHANGES CREDITS README.md
+
+ if use suid ; then
+ fowners root:pcap /usr/sbin/tcpdump
+ fperms 4110 /usr/sbin/tcpdump
+ fi
+}
+
+pkg_postinst() {
+ use suid && elog "To let normal users run tcpdump, add them to the pcap group."
+}