summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-04-09 20:39:19 -0500
committerJohn Helmert III <ajak@gentoo.org>2021-04-09 20:40:02 -0500
commitfb9f891f303aa9eb0cb55001ebb137d9e848eb0e (patch)
treef972b7b04835e914737a5f0c017440f52658af28 /net-analyzer
parentnet-analyzer/pmacct: drop 1.7.5 (diff)
downloadgentoo-fb9f891f303aa9eb0cb55001ebb137d9e848eb0e.tar.gz
gentoo-fb9f891f303aa9eb0cb55001ebb137d9e848eb0e.tar.bz2
gentoo-fb9f891f303aa9eb0cb55001ebb137d9e848eb0e.zip
net-analyzer/pmacct: update live
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/pmacct/pmacct-999999.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/net-analyzer/pmacct/pmacct-999999.ebuild b/net-analyzer/pmacct/pmacct-999999.ebuild
index 88a7b0b03c6c..8c0c97e73b16 100644
--- a/net-analyzer/pmacct/pmacct-999999.ebuild
+++ b/net-analyzer/pmacct/pmacct-999999.ebuild
@@ -13,7 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="
- +bgp-bins +bmp-bins geoip geoipv2 jansson kafka +l2 mysql ndpi nflog plabel
+ +bgp-bins +bmp-bins geoip geoipv2 jansson kafka +l2 mysql ndpi nflog
postgres rabbitmq sqlite +st-bins +traffic-bins zmq
"
REQUIRED_USE="
@@ -22,24 +22,23 @@ REQUIRED_USE="
rabbitmq? ( jansson )
"
-RDEPEND="
- net-libs/libpcap
+RDEPEND="net-libs/libpcap
geoip? ( dev-libs/geoip )
geoipv2? ( dev-libs/libmaxminddb )
jansson? ( dev-libs/jansson )
kafka? ( dev-libs/librdkafka )
- mysql? ( dev-db/mysql-connector-c:0= )
+ mysql? (
+ dev-db/mysql-connector-c:0=
+ sys-process/numactl
+ )
ndpi? ( >=net-libs/nDPI-3.2:= )
nflog? ( net-libs/libnetfilter_log )
postgres? ( dev-db/postgresql:* )
rabbitmq? ( net-libs/rabbitmq-c )
sqlite? ( =dev-db/sqlite-3* )
- zmq? ( >=net-libs/zeromq-4.2.0:= )
-"
+ zmq? ( >=net-libs/zeromq-4.2.0:= )"
DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
-"
+BDEPEND="virtual/pkgconfig"
DOCS=(
CONFIG-KEYS ChangeLog FAQS QUICKSTART UPGRADE
@@ -67,13 +66,13 @@ src_configure() {
$(use_enable mysql) \
$(use_enable ndpi) \
$(use_enable nflog) \
- $(use_enable plabel) \
$(use_enable postgres pgsql) \
$(use_enable rabbitmq) \
$(use_enable sqlite sqlite3) \
$(use_enable st-bins) \
$(use_enable traffic-bins) \
$(use_enable zmq) \
+ --without-external-deps \
--disable-debug \
--disable-mongodb
}