summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-06 09:09:53 +0000
committerSam James <sam@gentoo.org>2022-02-06 09:12:35 +0000
commitfda0cd2b9a57ef7e4d8e6e44bbf1d675ccb0feea (patch)
tree3115a65130a3e58c1b4787d31b70b870a043da9c /net-analyzer
parentdev-java/commons-collections: Drop 4.1-r1 (diff)
downloadgentoo-fda0cd2b9a57ef7e4d8e6e44bbf1d675ccb0feea.tar.gz
gentoo-fda0cd2b9a57ef7e4d8e6e44bbf1d675ccb0feea.tar.bz2
gentoo-fda0cd2b9a57ef7e4d8e6e44bbf1d675ccb0feea.zip
net-analyzer/sancp: fix musl build
Closes: https://bugs.gentoo.org/832421 CLoses: https://bugs.gentoo.org/714662 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sancp/Manifest1
-rw-r--r--net-analyzer/sancp/sancp-1.6.1-r7.ebuild24
2 files changed, 11 insertions, 14 deletions
diff --git a/net-analyzer/sancp/Manifest b/net-analyzer/sancp/Manifest
index 5334b6da520f..82188b274820 100644
--- a/net-analyzer/sancp/Manifest
+++ b/net-analyzer/sancp/Manifest
@@ -1,3 +1,4 @@
+DIST sancp-1.6.1-musl.patch.bz2 7013 BLAKE2B a54c3a3c45b1029a95451a21de2b42497434dff6715cb173db5f04293740f3e03869900e23c571dae97a563a9b7fdce76c4295f3267857a77a074a65e79f3b53 SHA512 3310577acef1d16b87b51924ed6fbb82b491afc5646555667fcd2430aef1b0dd5f0ee510c6356eebd32402b79eb8e9f5032955b5194517acc0c055da8dd74fc2
DIST sancp-1.6.1.fix200511.a.patch 662 BLAKE2B d3d5114662f3904db4052d581b3a95f07f5a492b439958bd64149ca6f9aaf48f2d2d9cf2094500b9ab829b3a06358180893637ed6d3f502ef46f87dfe8527ccc SHA512 87662d9ea863a3a2468b7b64c81a191d34c81348eab9374245a73d3ed63cf2f25df54561f092f3713d516d9cc4eb553d4d7286fd920676a301e61669a023142e
DIST sancp-1.6.1.fix200511.b.patch 870 BLAKE2B 18ad38c37f11aa1c4804400db5475323db25e0c135d3478e9c81af3a0a3885f397521fdf9b58825216fdd16ec2e2616584f3dc9e175e76d64c7125a767b2c029 SHA512 a54bbec1ce3799f83c006f7375297bafee85b12a90361f1f5dbbf46c936193c7e0f1196483a2bdf560019e93ceffe9129b3c01322eedc397e5dfa3a1a6b76b81
DIST sancp-1.6.1.fix200601.c.patch 3578 BLAKE2B 7c7e5ef0e1967d41f731d3c79f4273a4ebfc922159ada1940ba4635f6f82e63ed55faeffe53636d2c8fd96d57e1516211fff8852c73876d019fc13d59f4ace9d SHA512 3d15028d33e7dbddc74d8c6eefac6d66e357f024dca15afdfb8156b0cf969ab093c26baa43ebf7c1ac88f4275ef4bdc91c1cc69c5aa7b439a042ed966edea30f
diff --git a/net-analyzer/sancp/sancp-1.6.1-r7.ebuild b/net-analyzer/sancp/sancp-1.6.1-r7.ebuild
index e18588995cbb..f3ea7b0a3461 100644
--- a/net-analyzer/sancp/sancp-1.6.1-r7.ebuild
+++ b/net-analyzer/sancp/sancp-1.6.1-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,15 +7,14 @@ inherit toolchain-funcs
DESCRIPTION="collect network traffic statistics and store them in pcap format"
HOMEPAGE="https://sourceforge.net/projects/sancp/"
-SRC_URI="
- http://www.metre.net/files/${P}.tar.gz
+SRC_URI="http://www.metre.net/files/${P}.tar.gz
http://sancp.sourceforge.net/${PN}-1.6.1.fix200511.a.patch
http://sancp.sourceforge.net/${PN}-1.6.1.fix200511.b.patch
http://sancp.sourceforge.net/${PN}-1.6.1.fix200601.c.patch
http://sancp.sourceforge.net/${PN}-1.6.1.fix200606.d.patch
-"
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-1.6.1-musl.patch.bz2"
-LICENSE="QPL-1.0 GPL-2" # GPL-2 for init script
+LICENSE="QPL-1.0 GPL-2" # GPL-2 for init script
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="sguil"
@@ -27,20 +26,17 @@ RDEPEND="
DEPEND="${RDEPEND}"
PATCHES=(
+ "${DISTDIR}"/${PN}-1.6.1.fix200511.a.patch
+ "${DISTDIR}"/${PN}-1.6.1.fix200511.b.patch
+ # bug 138337
+ "${DISTDIR}"/${PN}-1.6.1.fix200601.c.patch
+ "${DISTDIR}"/${PN}-1.6.1.fix200606.d.patch
"${FILESDIR}"/${PN}-1.6.1-compiler.patch
"${FILESDIR}"/${PN}-1.6.1-gcc6.patch
"${FILESDIR}"/${PN}-1.6.1-extern.patch
+ "${WORKDIR}"/${PN}-1.6.1-musl.patch
)
-src_prepare() {
- eapply "${DISTDIR}"/${PN}-1.6.1.fix200511.a.patch
- eapply "${DISTDIR}"/${PN}-1.6.1.fix200511.b.patch
- # bug 138337
- eapply "${DISTDIR}"/${PN}-1.6.1.fix200601.c.patch
- eapply "${DISTDIR}"/${PN}-1.6.1.fix200606.d.patch
- default
-}
-
src_compile() {
tc-export CC CXX
emake CFLAGS="${CXXFLAGS}"