summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-10-02 08:25:46 +0200
committerJeroen Roovers <jer@gentoo.org>2019-10-02 08:25:58 +0200
commitfe179474fcb392b2dc604b5136b84f6c6b399def (patch)
tree187429eba05b7e9ac66fe87b9d6d7eb079bd04f6 /net-analyzer
parentdev-haskell/cryptonite: restored accidentally dropped stable keywords (diff)
downloadgentoo-fe179474fcb392b2dc604b5136b84f6c6b399def.tar.gz
gentoo-fe179474fcb392b2dc604b5136b84f6c6b399def.tar.bz2
gentoo-fe179474fcb392b2dc604b5136b84f6c6b399def.zip
net-analyzer/tcpdump: Version 4.9.3
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpdump/Manifest1
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.9.3.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/net-analyzer/tcpdump/Manifest b/net-analyzer/tcpdump/Manifest
index f079afe4fa80..59c9ed328855 100644
--- a/net-analyzer/tcpdump/Manifest
+++ b/net-analyzer/tcpdump/Manifest
@@ -1 +1,2 @@
DIST tcpdump-4.9.2.tar.gz 2298386 BLAKE2B b7e90d1091affa6f4734a622f23565976b0cb5be8c0afa12656f52acea29384306f2875477dc180b5dc60110a57e0f30f5654ba27dac9f03ff610ca0548de0a7 SHA512 e1bc19a5867d6e3628f3941bdf3ec831bf13784f1233ca1bccc46aac1702f47ee9357d7ff0ca62cddf211b3c8884488c21144cabddd92c861e32398cd8f7c44b
+DIST tcpdump-4.9.3.tar.gz 2333119 BLAKE2B 21e13fc40d98cfac0bbd5513580cf98313df1f8fea24c48f045f70d494aea3e75230b8481049660c109f9179015c3164f3e3b31acc76c0bfb1f2da5039f1834e SHA512 3aec673f78b996a4df884b1240e5d0a26a2ca81ee7aca8a2e6d50255bb53476e008a5ced4409e278a956710d8a4d31d85bbb800c9f1aab92b0b1046b59292a22
diff --git a/net-analyzer/tcpdump/tcpdump-4.9.3.ebuild b/net-analyzer/tcpdump/tcpdump-4.9.3.ebuild
new file mode 100644
index 000000000000..27466b8c51c4
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-4.9.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic toolchain-funcs user
+
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+HOMEPAGE="
+ http://www.tcpdump.org/
+ https://github.com/the-tcpdump-group/tcpdump
+"
+SRC_URI="
+ http://www.tcpdump.org/release/${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+drop-root libressl smi ssl samba suid test"
+
+RDEPEND="
+ drop-root? ( sys-libs/libcap-ng )
+ net-libs/libpcap
+ smi? ( net-libs/libsmi )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6m:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ drop-root? ( virtual/pkgconfig )
+ test? (
+ || ( app-arch/sharutils sys-freebsd/freebsd-ubin )
+ dev-lang/perl
+ )
+"
+
+pkg_setup() {
+ if use drop-root || use suid; then
+ enewgroup tcpdump
+ enewuser tcpdump -1 -1 -1 tcpdump
+ fi
+}
+
+src_configure() {
+ if use drop-root; then
+ append-cppflags -DHAVE_CAP_NG_H
+ export LIBS=$( $(tc-getPKG_CONFIG) --libs libcap-ng )
+ fi
+
+ econf \
+ $(use_enable samba smb) \
+ $(use_with drop-root chroot '') \
+ $(use_with smi) \
+ $(use_with ssl crypto "${EPREFIX}/usr") \
+ $(usex drop-root "--with-user=tcpdump" "")
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]] || ! use drop-root; then
+ emake check
+ else
+ ewarn "If you want to run the test suite, make sure you either"
+ ewarn "set FEATURES=userpriv or set USE=-drop-root"
+ fi
+}
+
+src_install() {
+ dosbin tcpdump
+ doman tcpdump.1
+ dodoc *.awk
+ dodoc CHANGES CREDITS README.md
+
+ if use suid; then
+ fowners root:tcpdump /usr/sbin/tcpdump
+ fperms 4110 /usr/sbin/tcpdump
+ fi
+}
+
+pkg_preinst() {
+ if use drop-root || use suid; then
+ enewgroup tcpdump
+ enewuser tcpdump -1 -1 -1 tcpdump
+ fi
+}
+
+pkg_postinst() {
+ use suid && elog "To let normal users run tcpdump add them into tcpdump group."
+}