summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-10-24 11:45:08 +0200
committerJeroen Roovers <jer@gentoo.org>2018-10-24 11:45:51 +0200
commit35edd05a5530db10454d9347720e36ae954a20eb (patch)
treeb2a7f061b0bb8e59fc3f385a5c08e5cc9cbd8484 /net-dns/c-ares/c-ares-1.15.0.ebuild
parentdev-python/geventhttpclient: fix ImportError while collecting tests (diff)
downloadgentoo-35edd05a5530db10454d9347720e36ae954a20eb.tar.gz
gentoo-35edd05a5530db10454d9347720e36ae954a20eb.tar.bz2
gentoo-35edd05a5530db10454d9347720e36ae954a20eb.zip
net-dns/c-ares: Version 1.15.0
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-dns/c-ares/c-ares-1.15.0.ebuild')
-rw-r--r--net-dns/c-ares/c-ares-1.15.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-dns/c-ares/c-ares-1.15.0.ebuild b/net-dns/c-ares/c-ares-1.15.0.ebuild
new file mode 100644
index 000000000000..c90ba00fe1b5
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.15.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="https://c-ares.haxx.se/"
+SRC_URI="https://${PN}.haxx.se/download/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+IUSE="static-libs"
+
+# Subslot = SONAME of libcares.so.2
+SLOT="0/2"
+
+DOCS=( AUTHORS CHANGES NEWS README.md RELEASE-NOTES TODO )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ares_build.h
+)
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-1.12.0-remove-tests.patch
+ eapply_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-nonblocking \
+ --enable-symbol-hiding \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+}