summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-09-08 22:17:14 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2017-09-08 22:38:54 +0300
commit3aa9e882e5ff0f1f74352835953fc8a648b9f43e (patch)
tree52973d60d20a8f4da6a5d34890d432b0400c377f /net-libs/gnutls
parentnet-firewall/firehol: Bump to 3.1.4 (diff)
downloadgentoo-3aa9e882e5ff0f1f74352835953fc8a648b9f43e.tar.gz
gentoo-3aa9e882e5ff0f1f74352835953fc8a648b9f43e.tar.bz2
gentoo-3aa9e882e5ff0f1f74352835953fc8a648b9f43e.zip
net-libs/gnutls: disable hw accesseleration at cygwin
Thanks: Michael Haubenwallner Closes: https://github.com/gentoo/gentoo/pull/5636 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'net-libs/gnutls')
-rw-r--r--net-libs/gnutls/gnutls-3.5.15.ebuild11
-rw-r--r--net-libs/gnutls/gnutls-3.6.0.ebuild11
2 files changed, 16 insertions, 6 deletions
diff --git a/net-libs/gnutls/gnutls-3.5.15.ebuild b/net-libs/gnutls/gnutls-3.5.15.ebuild
index 78dd42e46b52..f4f614daebed 100644
--- a/net-libs/gnutls/gnutls-3.5.15.ebuild
+++ b/net-libs/gnutls/gnutls-3.5.15.ebuild
@@ -89,9 +89,16 @@ multilib_src_configure() {
local libconf=($("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g'))
# TPM needs to be tested before being enabled
+ libconf+=( --without-tpm )
+
# hardware-accell is disabled on OSX because the asm files force
# GNU-stack (as doesn't support that) and when that's removed ld
# complains about duplicate symbols
+ [[ ${CHOST} == *-darwin* ]] && libconf+=( --disable-hardware-acceleration )
+
+ # Cygwin as does not understand these asm files at all
+ [[ ${CHOST} == *-cygwin* ]] && libconf+=( --disable-hardware-acceleration )
+
ECONF_SOURCE=${S} econf \
$(multilib_native_enable manpages) \
$(multilib_native_use_enable doc gtk-doc) \
@@ -117,9 +124,7 @@ multilib_src_configure() {
$(use_with zlib) \
--with-unbound-root-key-file="${EPREFIX}/etc/dnssec/root-anchors.txt" \
--without-included-libtasn1 \
- --without-tpm \
- "${libconf[@]}" \
- $([[ ${CHOST} == *-darwin* ]] && echo --disable-hardware-acceleration)
+ "${libconf[@]}"
}
multilib_src_install_all() {
diff --git a/net-libs/gnutls/gnutls-3.6.0.ebuild b/net-libs/gnutls/gnutls-3.6.0.ebuild
index bca21f056160..c8182318d3df 100644
--- a/net-libs/gnutls/gnutls-3.6.0.ebuild
+++ b/net-libs/gnutls/gnutls-3.6.0.ebuild
@@ -88,9 +88,16 @@ multilib_src_configure() {
local libconf=($("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g'))
# TPM needs to be tested before being enabled
+ libconf+=( --without-tpm )
+
# hardware-accell is disabled on OSX because the asm files force
# GNU-stack (as doesn't support that) and when that's removed ld
# complains about duplicate symbols
+ [[ ${CHOST} == *-darwin* ]] && libconf+=( --disable-hardware-acceleration )
+
+ # Cygwin as does not understand these asm files at all
+ [[ ${CHOST} == *-cygwin* ]] && libconf+=( --disable-hardware-acceleration )
+
ECONF_SOURCE=${S} econf \
$(multilib_native_enable manpages) \
$(multilib_native_use_enable doc gtk-doc) \
@@ -113,9 +120,7 @@ multilib_src_configure() {
$(use_with pkcs11 p11-kit) \
--with-unbound-root-key-file="${EPREFIX}/etc/dnssec/root-anchors.txt" \
--without-included-libtasn1 \
- --without-tpm \
- "${libconf[@]}" \
- $([[ ${CHOST} == *-darwin* ]] && echo --disable-hardware-acceleration)
+ "${libconf[@]}"
}
multilib_src_install_all() {