summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-01-07 12:29:22 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-07 21:33:44 -0500
commit64ce94937cc7e8d4e13af758e6c7462bc170f73b (patch)
tree9ebb07f2cf2bffa6989f489ba5dfdc8947204078 /net-libs/libmbim/libmbim-1.24.4.ebuild
parentnet-libs/mbedtls: version bumps to 2.16.9 and 2.25.0, bug #764317 (diff)
downloadgentoo-64ce94937cc7e8d4e13af758e6c7462bc170f73b.tar.gz
gentoo-64ce94937cc7e8d4e13af758e6c7462bc170f73b.tar.bz2
gentoo-64ce94937cc7e8d4e13af758e6c7462bc170f73b.zip
net-libs/libmbim: 1.24.4 version bump
Closes: https://bugs.gentoo.org/710788 Closes: https://bugs.gentoo.org/761733 Closes: https://github.com/gentoo/gentoo/pull/18985 Signed-off-by: Craig Andrews <candrews@gentoo.org> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/libmbim/libmbim-1.24.4.ebuild')
-rw-r--r--net-libs/libmbim/libmbim-1.24.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/libmbim/libmbim-1.24.4.ebuild b/net-libs/libmbim/libmbim-1.24.4.ebuild
new file mode 100644
index 000000000000..6aa324455bcc
--- /dev/null
+++ b/net-libs/libmbim/libmbim-1.24.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib
+
+DESCRIPTION="Mobile Broadband Interface Model (MBIM) modem protocol helper library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libmbim/ https://gitlab.freedesktop.org/mobile-broadband/libmbim"
+SRC_URI="https://www.freedesktop.org/software/libmbim/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="udev"
+
+RDEPEND=">=dev-libs/glib-2.48:2
+ udev? ( dev-libs/libgudev:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --disable-Werror \
+ --disable-static \
+ --disable-gtk-doc \
+ $(use_with udev)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}