summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 21:01:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 10:37:24 +0100
commit31e21551da418ddc7a177c7c869070e9acca817c (patch)
tree0ad1bfcfc7068989bcb92c3f4499f5a84cfd8c95 /net-libs/nghttp3
parent*/*: Switch games proj to cmake.eclass (diff)
downloadgentoo-31e21551da418ddc7a177c7c869070e9acca817c.tar.gz
gentoo-31e21551da418ddc7a177c7c869070e9acca817c.tar.bz2
gentoo-31e21551da418ddc7a177c7c869070e9acca817c.zip
*/*: Switch candrews' packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/nghttp3-0_pre20190912.ebuild5
-rw-r--r--net-libs/nghttp3/nghttp3-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild b/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
index 82c8375e72b0..03aecea14f7e 100644
--- a/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
+++ b/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == 9999 ]] ; then
@@ -33,9 +34,9 @@ multilib_src_configure() {
-DENABLE_EXAMPLES=OFF
-DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_test() {
- cmake-utils_src_make check
+ cmake_build check
}
diff --git a/net-libs/nghttp3/nghttp3-9999.ebuild b/net-libs/nghttp3/nghttp3-9999.ebuild
index 7df7eb88b3ac..d6e17cdeb225 100644
--- a/net-libs/nghttp3/nghttp3-9999.ebuild
+++ b/net-libs/nghttp3/nghttp3-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
if [[ ${PV} == 9999 ]] ; then
@@ -31,9 +32,9 @@ multilib_src_configure() {
-DENABLE_EXAMPLES=OFF
-DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_test() {
- cmake-utils_src_make check
+ cmake_build check
}