summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-13 23:35:14 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-13 23:36:01 +0200
commit6f603892beae75d85e37be7448f9528cb71c2e83 (patch)
tree2d42080183b2d6e6699c7d5cbe3d7ec24a4d4ef0 /net-libs/nodejs
parentnet-libs/nodejs: support python3_10 (diff)
downloadgentoo-6f603892beae75d85e37be7448f9528cb71c2e83.tar.gz
gentoo-6f603892beae75d85e37be7448f9528cb71c2e83.tar.bz2
gentoo-6f603892beae75d85e37be7448f9528cb71c2e83.zip
net-libs/nodejs-12.22.1-r1: remove test restriction
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/nodejs-12.22.1-r1.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/net-libs/nodejs/nodejs-12.22.1-r1.ebuild b/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
index 754e3973f544..9c4fe05c005f 100644
--- a/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
@@ -30,6 +30,8 @@ REQUIRED_USE="
system-ssl? ( ssl )
"
+RESTRICT="!test? ( test )"
+
RDEPEND="
>=app-arch/brotli-1.0.9
>=dev-libs/libuv-1.39.0:=
@@ -58,7 +60,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-12.22.1-v8_icu69.patch
"${FILESDIR}"/${PN}-99999999-llhttp.patch
)
-RESTRICT="test"
pkg_pretend() {
(use x86 && ! use cpu_flags_x86_sse2) && \
@@ -101,12 +102,8 @@ src_prepare() {
sed -i -e "/'-O3'/d" common.gypi node.gypi || die
- # Avoid a test that I've only been able to reproduce from emerge. It doesnt
- # seem sandbox related either (invoking it from a sandbox works fine).
- # The issue is that no stdin handle is openened when asked for one.
- # It doesn't really belong upstream , so it'll just be removed until someone
- # with more gentoo-knowledge than me (jbergstroem) figures it out.
- rm test/parallel/test-stdout-close-unref.js || die
+ # Known-to-fail test of a deprecated, legacy HTTP parser. Just don't bother.
+ rm -f test/parallel/test-http-transfer-encoding-smuggling-legacy.js
# debug builds. change install path, remove optimisations and override buildtype
if use debug; then
@@ -229,8 +226,14 @@ src_install() {
}
src_test() {
+ # parallel/test-fs-mkdir is known to fail with FEATURES=usersandbox
+ if has usersandbox ${FEATURES}; then
+ ewarn "You are emerging ${P} with 'usersandbox' enabled." \
+ "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ fi
+
out/${BUILDTYPE}/cctest || die
- "${PYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
+ "${PYTHON}" tools/test.py --mode=${BUILDTYPE,,} --flaky-tests=dontcare -J message parallel sequential || die
}
pkg_postinst() {