summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-19 17:00:29 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-19 17:00:53 +0100
commitf5d2c73dd61347dfd1c906eaeeebf551e0efc800 (patch)
tree128378dbee7a49a6734285069c068564d6df1256 /net-libs
parentapp-crypt/yubikey-manager: functional tests on x86 (diff)
downloadgentoo-f5d2c73dd61347dfd1c906eaeeebf551e0efc800.tar.gz
gentoo-f5d2c73dd61347dfd1c906eaeeebf551e0efc800.tar.bz2
gentoo-f5d2c73dd61347dfd1c906eaeeebf551e0efc800.zip
net-libs/libpsl: Don't use REQUIRED_USE
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libpsl/libpsl-0.20.2.ebuild35
1 files changed, 19 insertions, 16 deletions
diff --git a/net-libs/libpsl/libpsl-0.20.2.ebuild b/net-libs/libpsl/libpsl-0.20.2.ebuild
index 6eed8f0695e3..b8ec1fa9700b 100644
--- a/net-libs/libpsl/libpsl-0.20.2.ebuild
+++ b/net-libs/libpsl/libpsl-0.20.2.ebuild
@@ -14,10 +14,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="icu +idn +man"
-REQUIRED_USE="^^ ( icu idn )"
-
RDEPEND="
- icu? ( dev-libs/icu:=[${MULTILIB_USEDEP}] )
+ icu? ( !idn? ( dev-libs/icu:=[${MULTILIB_USEDEP}] ) )
idn? (
dev-libs/libunistring[${MULTILIB_USEDEP}]
net-dns/libidn2:=[${MULTILIB_USEDEP}]
@@ -34,6 +32,13 @@ BDEPEND="
man? ( dev-libs/libxslt )
"
+pkg_pretend() {
+ if use icu && use idn ; then
+ ewarn "\"icu\" and \"idn\" USE flags are enabled."
+ ewarn "Using \"idn\"."
+ fi
+}
+
multilib_src_configure() {
local myeconfargs=(
--disable-asan
@@ -42,19 +47,17 @@ multilib_src_configure() {
$(use_enable man)
)
- if use icu || use idn ; then
- if use icu ; then
- myeconfargs+=(
- --enable-builtin=libicu
- --enable-runtime=libicu
- )
- fi
- if use idn ; then
- myeconfargs+=(
- --enable-builtin=libidn2
- --enable-runtime=libidn2
- )
- fi
+ # Prefer idn even if icu is in USE as well
+ if use idn ; then
+ myeconfargs+=(
+ --enable-builtin=libidn2
+ --enable-runtime=libidn2
+ )
+ elif use icu ; then
+ myeconfargs+=(
+ --enable-builtin=libicu
+ --enable-runtime=libicu
+ )
else
myeconfargs+=( --disable-runtime )
fi