summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-08 13:44:41 -0500
committerTim Harder <radhermit@gentoo.org>2017-10-08 13:44:41 -0500
commitf97fa70d2cebe914a21f94eed58c3150125f56fc (patch)
tree1b54ef4a6dbcd02551378954c5e9c53e951b4312 /net-mail/getmail/getmail-5.4.ebuild
parentmedia-gfx/feh: version bump to 2.21 (diff)
downloadgentoo-f97fa70d2cebe914a21f94eed58c3150125f56fc.tar.gz
gentoo-f97fa70d2cebe914a21f94eed58c3150125f56fc.tar.bz2
gentoo-f97fa70d2cebe914a21f94eed58c3150125f56fc.zip
net-mail/getmail: version bump to 5.4
Diffstat (limited to 'net-mail/getmail/getmail-5.4.ebuild')
-rw-r--r--net-mail/getmail/getmail-5.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-mail/getmail/getmail-5.4.ebuild b/net-mail/getmail/getmail-5.4.ebuild
new file mode 100644
index 000000000000..a213f82d8658
--- /dev/null
+++ b/net-mail/getmail/getmail-5.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x86-macos ~x64-solaris"
+IUSE="ssl"
+
+python_prepare_all() {
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}