summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-10-24 16:29:05 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2016-10-24 16:44:37 -0700
commit573e4e7200e4d2c23a24ddbe2eb302150aa8b4a4 (patch)
tree5923b436845025b491641c7c79f6e6f10b25d564 /net-misc/netifrc/netifrc-0.5.0.ebuild
parentdev-python/twisted: Version bump (diff)
downloadgentoo-573e4e7200e4d2c23a24ddbe2eb302150aa8b4a4.tar.gz
gentoo-573e4e7200e4d2c23a24ddbe2eb302150aa8b4a4.tar.bz2
gentoo-573e4e7200e4d2c23a24ddbe2eb302150aa8b4a4.zip
net-misc/netifrc: bump, MANY fixes.
This release of netifrc should hopefully represent the next stable candidate. The 0.3.x and 0.4.x series had some bugs that should not be in stable. One specific change to note, is that if an address or route is already configured on an interface, prior to starting the interface service, the interface will now start successfully, whereas it would previously fail. If the parameters on the existing route and new route are slightly different, this may lead to non-deterministic behavior. Bugs fixed: 420941, 588872: l2tp/dummy/hsr support. 487208: support busybox better, no scope=host on loopback. 488250, 488260, 488262: better IPv6 address handling. 489398: more reliable interface startup 507346: resolvconf-gentoo renamed to openresolv 524156: DHCP classless static routes for udhcpc 525958: Better POSIX sh support 540728, 547906: macchanger 1.7 support 545364: Switch to /run instead of /var/run 575128: newer udev support 596234: New iproute keywords: noprefixroute mngtmpaddr 596844: metric_SSID support Package-Manager: portage-2.3.2 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'net-misc/netifrc/netifrc-0.5.0.ebuild')
-rw-r--r--net-misc/netifrc/netifrc-0.5.0.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/netifrc/netifrc-0.5.0.ebuild b/net-misc/netifrc/netifrc-0.5.0.ebuild
new file mode 100644
index 000000000000..918a70a6dda8
--- /dev/null
+++ b/net-misc/netifrc/netifrc-0.5.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils systemd udev
+
+DESCRIPTION="Gentoo Network Interface Management Scripts"
+HOMEPAGE="https://www.gentoo.org/proj/en/base/openrc/"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+ #EGIT_REPO_URI="git://github.com/gentoo/netifrc" # Alternate
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~robbat2/distfiles/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="kernel_linux? ( virtual/pkgconfig )
+ !<sys-fs/udev-172"
+RDEPEND="sys-apps/gentoo-functions
+ >=sys-apps/openrc-0.12"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ local ver="git-${EGIT_VERSION:0:6}"
+ sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/git.mk || die
+ einfo "Producing ChangeLog from Git history"
+ GIT_DIR="${S}/.git" git log >"${S}"/ChangeLog
+ fi
+
+ # Allow user patches to be applied without modifying the ebuild
+ epatch_user
+}
+
+src_compile() {
+ MAKE_ARGS="${MAKE_ARGS}
+ UDEVDIR=${EPREFIX}$(get_udevdir)
+ LIBEXECDIR=${EPREFIX}/lib/${PN} PF=${PF}"
+
+ use prefix && MAKE_ARGS="${MAKE_ARGS} MKPREFIX=yes PREFIX=${EPREFIX}"
+
+ emake ${MAKE_ARGS} all
+}
+
+src_install() {
+ emake ${MAKE_ARGS} DESTDIR="${D}" install
+ dodoc README CREDITS FEATURE-REMOVAL-SCHEDULE STYLE TODO ChangeLog
+
+ # Install the service file
+ LIBEXECDIR=${EPREFIX}/lib/${PN}
+ UNIT_DIR="$(systemd_get_unitdir)"
+ sed "s:@LIBEXECDIR@:${LIBEXECDIR}:" "${S}/systemd/net_at.service.in" > "${T}/net_at.service" || die
+ systemd_newunit "${T}/net_at.service" 'net@.service'
+ dosym "${UNIT_DIR#${EPREFIX}}/net@.service" "${UNIT_DIR#${EPREFIX}}/net@lo.service"
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}"/etc/conf.d/net && -z $REPLACING_VERSIONS ]]; then
+ elog "The network configuration scripts will use dhcp by"
+ elog "default to set up your interfaces."
+ elog "If you need to set up something more complete, see"
+ elog "${EROOT}/usr/share/doc/${P}/README"
+ fi
+}