summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/vpncwatch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/vpncwatch')
-rw-r--r--net-misc/vpncwatch/Manifest2
-rw-r--r--net-misc/vpncwatch/files/vpncwatch-1.7-Makefile.patch21
-rw-r--r--net-misc/vpncwatch/files/vpncwatch-1.7-gcc4.3.patch11
-rw-r--r--net-misc/vpncwatch/files/vpncwatch-1.7-literal.patch11
-rw-r--r--net-misc/vpncwatch/files/vpncwatch-1.8-Makefile.patch23
-rw-r--r--net-misc/vpncwatch/files/vpncwatch-1.8.1-Makefile.patch23
-rw-r--r--net-misc/vpncwatch/metadata.xml10
-rw-r--r--net-misc/vpncwatch/vpncwatch-1.8.1.ebuild29
-rw-r--r--net-misc/vpncwatch/vpncwatch-1.8.ebuild29
9 files changed, 159 insertions, 0 deletions
diff --git a/net-misc/vpncwatch/Manifest b/net-misc/vpncwatch/Manifest
new file mode 100644
index 000000000000..b9db5ef429b6
--- /dev/null
+++ b/net-misc/vpncwatch/Manifest
@@ -0,0 +1,2 @@
+DIST vpncwatch-1.8.1.tar.gz 17420 SHA256 fb69cfc17abacc1c1ccb56f42ebdf5fafe20f7971eb917a90863daed69b72562 SHA512 f5f5f68e2644ee3748a811505025155e77a7d3e345ddfc2f847674aa5d7e9e8be86d10708aeefc521ac747744e4f7edc3853ff230022aee7b098e8d0a35db5c2 WHIRLPOOL 3e5edd96d791aeb57a8ac96542fe200acd6d4d0fcff33b9576636bbccab957e5f168cd27fe52a61afce8cc5a55b940e22471243023d78e1e6c637883f31fc0ac
+DIST vpncwatch-1.8.tar.gz 16356 SHA256 bc5ea19ef4020ed7ecdff3a7c4bdf981590c1a7c62e1c92170e8360782a89626 SHA512 33771af327995be170e98169e4f5594a8298a613b865f1fb3157b0bccb8218e81a4bb26c7d9783d2f7d0963dafa04d21100889c5c710166b4a1e1487f945dceb WHIRLPOOL de524723042357674520c68034c9ecaadbfac94b299c42401565ea284bbc5f794bdd38f2c5a9bda1ed5ed1102febbf191ff325f3ec6b18103612ca67846c6014
diff --git a/net-misc/vpncwatch/files/vpncwatch-1.7-Makefile.patch b/net-misc/vpncwatch/files/vpncwatch-1.7-Makefile.patch
new file mode 100644
index 000000000000..f32e538ade40
--- /dev/null
+++ b/net-misc/vpncwatch/files/vpncwatch-1.7-Makefile.patch
@@ -0,0 +1,21 @@
+--- Makefile 2008-02-04 09:44:34.000000000 +0100
++++ Makefile.new 2009-02-08 18:49:06.061291832 +0100
+@@ -10,7 +10,7 @@
+ OBJS = vpncwatch.o proc.o net.o
+
+ CC ?= gcc
+-CFLAGS = -D_GNU_SOURCE -O2 -Wall -Werror
++CFLAGS += -D_GNU_SOURCE
+
+ vpncwatch: $(OBJS)
+ $(CC) $(CFLAGS) -o $@ $(OBJS)
+@@ -13,7 +13,7 @@
+ CFLAGS = -D_GNU_SOURCE -O2 -Wall -Werror
+
+ vpncwatch: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $(OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS)
+
+ .c.o:
+ $(CC) $(CFLAGS) -c -o $@ $<
+
diff --git a/net-misc/vpncwatch/files/vpncwatch-1.7-gcc4.3.patch b/net-misc/vpncwatch/files/vpncwatch-1.7-gcc4.3.patch
new file mode 100644
index 000000000000..91c3f5b28399
--- /dev/null
+++ b/net-misc/vpncwatch/files/vpncwatch-1.7-gcc4.3.patch
@@ -0,0 +1,11 @@
+--- vpncwatch.c.orig 2009-02-08 17:03:14.296036582 +0100
++++ vpncwatch.c 2009-02-08 17:02:56.932904474 +0100
+@@ -31,6 +31,7 @@
+ #include <arpa/inet.h>
+ #include <netdb.h>
+ #include <errno.h>
++#include <linux/limits.h>
+
+
+ #include "vpncwatch.h"
+
diff --git a/net-misc/vpncwatch/files/vpncwatch-1.7-literal.patch b/net-misc/vpncwatch/files/vpncwatch-1.7-literal.patch
new file mode 100644
index 000000000000..2944464c08bc
--- /dev/null
+++ b/net-misc/vpncwatch/files/vpncwatch-1.7-literal.patch
@@ -0,0 +1,11 @@
+--- net.c 2008-02-04 09:28:51.000000000 +0100
++++ net.c.new 2009-02-08 17:13:31.188241104 +0100
+@@ -53,7 +53,7 @@
+ /* get the server address */
+ if (inet_pton(AF_INET, chkhost, &(chksock.sin_addr.s_addr)) <= 0) {
+ if ((host = gethostbyname(chkhost)) == NULL) {
+- syslog(LOG_ERR, hstrerror(h_errno));
++ syslog(LOG_ERR, "%s", hstrerror(h_errno));
+ return 0;
+ }
+
diff --git a/net-misc/vpncwatch/files/vpncwatch-1.8-Makefile.patch b/net-misc/vpncwatch/files/vpncwatch-1.8-Makefile.patch
new file mode 100644
index 000000000000..cab556c95352
--- /dev/null
+++ b/net-misc/vpncwatch/files/vpncwatch-1.8-Makefile.patch
@@ -0,0 +1,23 @@
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 901e0ae..599499a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -10,13 +10,13 @@ OBJS = vpncwatch.o proc.o net.o
+ DISTFILES = AUTHORS COPYING README Makefile $(SRCS) $(HDRS) vpnc-watch.py
+
+ CC ?= gcc
+-CFLAGS = -D_GNU_SOURCE -O2 -Wall -Werror
++CFLAGS += -D_GNU_SOURCE -Wall
+
+ # Update version in vpncwatch.h as well
+ TAG = vpncwatch-1.8
+
+ vpncwatch: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $(OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS)
+
+ .c.o:
+ $(CC) $(CFLAGS) -c -o $@ $<
diff --git a/net-misc/vpncwatch/files/vpncwatch-1.8.1-Makefile.patch b/net-misc/vpncwatch/files/vpncwatch-1.8.1-Makefile.patch
new file mode 100644
index 000000000000..1f982ee76a3f
--- /dev/null
+++ b/net-misc/vpncwatch/files/vpncwatch-1.8.1-Makefile.patch
@@ -0,0 +1,23 @@
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 901e0ae..599499a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -10,13 +10,13 @@ OBJS = vpncwatch.o proc.o net.o
+ DISTFILES = AUTHORS COPYING README Makefile $(SRCS) $(HDRS) vpnc-watch.py
+
+ CC ?= gcc
+-CFLAGS = -D_GNU_SOURCE -O2 -Wall -Werror
++CFLAGS += -D_GNU_SOURCE -Wall
+
+ # Update version in vpncwatch.h as well
+ TAG = vpncwatch-1.8.1
+
+ vpncwatch: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $(OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS)
+
+ .c.o:
+ $(CC) $(CFLAGS) -c -o $@ $<
diff --git a/net-misc/vpncwatch/metadata.xml b/net-misc/vpncwatch/metadata.xml
new file mode 100644
index 000000000000..128fee4d65eb
--- /dev/null
+++ b/net-misc/vpncwatch/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">downloads/dcantrell</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/vpncwatch/vpncwatch-1.8.1.ebuild b/net-misc/vpncwatch/vpncwatch-1.8.1.ebuild
new file mode 100644
index 000000000000..1778947d5d27
--- /dev/null
+++ b/net-misc/vpncwatch/vpncwatch-1.8.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Keepalive daemon for vpnc on Linux systems"
+HOMEPAGE="http://github.com/dcantrell/vpncwatch/"
+SRC_URI="http://github.com/downloads/dcantrell/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-misc/vpnc"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-Makefile.patch"
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README ChangeLog AUTHORS
+}
diff --git a/net-misc/vpncwatch/vpncwatch-1.8.ebuild b/net-misc/vpncwatch/vpncwatch-1.8.ebuild
new file mode 100644
index 000000000000..47b432c72c29
--- /dev/null
+++ b/net-misc/vpncwatch/vpncwatch-1.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A keepalive daemon for vpnc on Linux systems"
+HOMEPAGE="http://github.com/dcantrell/vpncwatch/"
+SRC_URI="http://github.com/downloads/dcantrell/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-misc/vpnc"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-Makefile.patch"
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README ChangeLog AUTHORS
+}