summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-20 01:15:08 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-20 01:15:08 +0200
commit801c22f60d2525a87aef6cf66114de19e4130541 (patch)
tree1f7912f8b566fa2bcd0d3aac86aab0c467542968 /net-misc/wol
parentdev-python/python-language-server: Add Python 3.8 compatibility (diff)
downloadgentoo-801c22f60d2525a87aef6cf66114de19e4130541.tar.gz
gentoo-801c22f60d2525a87aef6cf66114de19e4130541.tar.bz2
gentoo-801c22f60d2525a87aef6cf66114de19e4130541.zip
net-misc/wol: don't call directly ar
Closes: https://bugs.gentoo.org/725186 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc/wol')
-rw-r--r--net-misc/wol/wol-0.7.1-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-misc/wol/wol-0.7.1-r2.ebuild b/net-misc/wol/wol-0.7.1-r2.ebuild
index 27e01462efda..8ee1f1db4070 100644
--- a/net-misc/wol/wol-0.7.1-r2.ebuild
+++ b/net-misc/wol/wol-0.7.1-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="Implements Wake On LAN (Magic Paket) functionality in a small program"
HOMEPAGE="http://ahh.sourceforge.net/wol/"
SRC_URI="mirror://sourceforge/ahh/${P}.tar.gz"
@@ -20,3 +22,7 @@ src_configure() {
econf ${myeconfargs[@]}
}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}