summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:57:38 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:30:10 +0100
commit80385f7be49672ccb60c0c19f38f10f55518e214 (patch)
treee776af9c247a143dbb8e3acd290f0569ca5203f4 /net-misc
parentnet-misc/lldpd: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-80385f7be49672ccb60c0c19f38f10f55518e214.tar.gz
gentoo-80385f7be49672ccb60c0c19f38f10f55518e214.tar.bz2
gentoo-80385f7be49672ccb60c0c19f38f10f55518e214.zip
net-misc/openvswitch: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openvswitch/openvswitch-2.14.1.ebuild2
-rw-r--r--net-misc/openvswitch/openvswitch-2.15.0.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/net-misc/openvswitch/openvswitch-2.14.1.ebuild b/net-misc/openvswitch/openvswitch-2.14.1.ebuild
index cb44e1d8be7e..c873cc5a5478 100644
--- a/net-misc/openvswitch/openvswitch-2.14.1.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.14.1.ebuild
@@ -123,6 +123,8 @@ src_install() {
pkg_postinst() {
use modules && linux-mod_pkg_postinst
+ tmpfiles_process openvswitch.conf
+
# only needed on non-systemd, but helps anyway
elog "Use the following command to create an initial database for ovsdb-server:"
elog " emerge --config =${CATEGORY}/${PF}"
diff --git a/net-misc/openvswitch/openvswitch-2.15.0.ebuild b/net-misc/openvswitch/openvswitch-2.15.0.ebuild
index 7f44d4ded567..83ea5328d7d0 100644
--- a/net-misc/openvswitch/openvswitch-2.15.0.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.15.0.ebuild
@@ -122,6 +122,8 @@ src_install() {
pkg_postinst() {
use modules && linux-mod_pkg_postinst
+ tmpfiles_process openvswitch.conf
+
# only needed on non-systemd, but helps anyway
elog "Use the following command to create an initial database for ovsdb-server:"
elog " emerge --config =${CATEGORY}/${PF}"