summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:57:29 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:30:10 +0100
commitae0671e33e5e8fb255704bd87fb1a646b6c74372 (patch)
treea5b9b68737c1e99c94ad6cfed85ff7e82c5352a5 /net-misc
parentnet-misc/exabgp: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-ae0671e33e5e8fb255704bd87fb1a646b6c74372.tar.gz
gentoo-ae0671e33e5e8fb255704bd87fb1a646b6c74372.tar.bz2
gentoo-ae0671e33e5e8fb255704bd87fb1a646b6c74372.zip
net-misc/lldpd: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/lldpd/lldpd-1.0.10-r1.ebuild4
-rw-r--r--net-misc/lldpd/lldpd-1.0.11-r1.ebuild4
-rw-r--r--net-misc/lldpd/lldpd-1.0.7-r1.ebuild4
-rw-r--r--net-misc/lldpd/lldpd-1.0.9-r1.ebuild4
4 files changed, 16 insertions, 0 deletions
diff --git a/net-misc/lldpd/lldpd-1.0.10-r1.ebuild b/net-misc/lldpd/lldpd-1.0.10-r1.ebuild
index 64eceb88cec4..426784b12135 100644
--- a/net-misc/lldpd/lldpd-1.0.10-r1.ebuild
+++ b/net-misc/lldpd/lldpd-1.0.10-r1.ebuild
@@ -100,3 +100,7 @@ src_install() {
systemd_dounit "${FILESDIR}"/${PN}.service
newtmpfiles "${FILESDIR}"/tmpfilesd ${PN}.conf
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}
diff --git a/net-misc/lldpd/lldpd-1.0.11-r1.ebuild b/net-misc/lldpd/lldpd-1.0.11-r1.ebuild
index d31dbbc2f76e..5aae55e4aaad 100644
--- a/net-misc/lldpd/lldpd-1.0.11-r1.ebuild
+++ b/net-misc/lldpd/lldpd-1.0.11-r1.ebuild
@@ -100,3 +100,7 @@ src_install() {
systemd_dounit "${FILESDIR}"/${PN}.service
newtmpfiles "${FILESDIR}"/tmpfilesd ${PN}.conf
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}
diff --git a/net-misc/lldpd/lldpd-1.0.7-r1.ebuild b/net-misc/lldpd/lldpd-1.0.7-r1.ebuild
index b2c5422b9445..857f1e6a8607 100644
--- a/net-misc/lldpd/lldpd-1.0.7-r1.ebuild
+++ b/net-misc/lldpd/lldpd-1.0.7-r1.ebuild
@@ -96,3 +96,7 @@ src_install() {
systemd_dounit "${FILESDIR}"/${PN}.service
newtmpfiles "${FILESDIR}"/tmpfilesd ${PN}.conf
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}
diff --git a/net-misc/lldpd/lldpd-1.0.9-r1.ebuild b/net-misc/lldpd/lldpd-1.0.9-r1.ebuild
index 9009b6cd9a30..97aadd996bed 100644
--- a/net-misc/lldpd/lldpd-1.0.9-r1.ebuild
+++ b/net-misc/lldpd/lldpd-1.0.9-r1.ebuild
@@ -96,3 +96,7 @@ src_install() {
systemd_dounit "${FILESDIR}"/${PN}.service
newtmpfiles "${FILESDIR}"/tmpfilesd ${PN}.conf
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}