summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-12-16 12:37:15 -0500
committerAnthony G. Basile <blueness@gentoo.org>2015-12-16 12:37:15 -0500
commit77b83b512601cabd6160e39fc7dcff18c2660b11 (patch)
tree7cf81b4f05d6ee9bdc6ef597e04c294d6adefa68 /net-p2p/litecoind
parentnet-p2p/litecoind: fix for API change in miniunpnc, bug #567080. (diff)
downloadgentoo-77b83b512601cabd6160e39fc7dcff18c2660b11.tar.gz
gentoo-77b83b512601cabd6160e39fc7dcff18c2660b11.tar.bz2
gentoo-77b83b512601cabd6160e39fc7dcff18c2660b11.zip
net-p2p/litecoind: fix executable GNU stack.
Package-Manager: portage-2.2.24
Diffstat (limited to 'net-p2p/litecoind')
-rw-r--r--net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild b/net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild
index 9c14a513bc6d..c7f70686e16c 100644
--- a/net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild
+++ b/net-p2p/litecoind/litecoind-0.10.2.2-r3.ebuild
@@ -6,7 +6,7 @@ EAPI=5
DB_VER="4.8"
-inherit autotools db-use eutils systemd user
+inherit autotools db-use eutils flag-o-matic systemd user
MyPV="${PV/_/-}"
MyPN="litecoin"
@@ -51,6 +51,9 @@ src_prepare() {
}
src_configure() {
+ # To avoid executable GNU stack.
+ append-ldflags -Wl,-z,noexecstack
+
local my_econf=
if use upnp; then
my_econf="${my_econf} --with-miniupnpc --enable-upnp-default"