summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2019-09-30 03:27:05 +0000
committerCraig Andrews <candrews@gentoo.org>2020-03-07 16:15:14 -0500
commit529e91eb1a8f1a55fa400d7ca7e9d63ae61df5e2 (patch)
treefb201a225ba3201f9c127b3add34b0cbb021b9fa /net-p2p
parentnet-p2p/bitcoind: Drop redundant versions (diff)
downloadgentoo-529e91eb1a8f1a55fa400d7ca7e9d63ae61df5e2.tar.gz
gentoo-529e91eb1a8f1a55fa400d7ca7e9d63ae61df5e2.tar.bz2
gentoo-529e91eb1a8f1a55fa400d7ca7e9d63ae61df5e2.zip
net-p2p/bitcoin{-qt,d}-0.16.3: Drop bitcoin_policy_rbf USE flag
It is now always enabled at build time. Users who don't like it can turn it off at runtime. Signed-off-by: Luke Dashjr <luke-jr+git@utopios.org> Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild17
-rw-r--r--net-p2p/bitcoin-qt/metadata.xml1
-rw-r--r--net-p2p/bitcoind/bitcoind-0.16.3.ebuild17
-rw-r--r--net-p2p/bitcoind/metadata.xml1
4 files changed, 8 insertions, 28 deletions
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild
index 0ee413a509bd..95339d5b90b1 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.16.3.ebuild
@@ -21,7 +21,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE="+asm +bip70 +bitcoin_policy_rbf dbus kde +libevent knots libressl +qrcode test upnp +wallet zeromq"
+IUSE="+asm +bip70 dbus kde +libevent knots libressl +qrcode test upnp +wallet zeromq"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -69,14 +69,9 @@ pkg_pretend() {
elog "For more information, see:"
elog "https://bitcoincore.org/en/2018/09/18/release-${PV}/"
fi
- if use bitcoin_policy_rbf; then
- elog "Replace By Fee policy is enabled: Your node will preferentially mine and"
- elog "relay transactions paying the highest fee, regardless of receive order."
- else
- elog "Replace By Fee policy is disabled: Your node will only accept the first"
- elog "transaction seen consuming a conflicting input, regardless of fee"
- elog "offered by later ones."
- fi
+ elog "Replace By Fee policy is now always enabled by default: Your node will"
+ elog "preferentially mine and relay transactions paying the highest fee, regardless"
+ elog "of receive order. To disable RBF, set mempoolreplacement=never in bitcoin.conf"
}
src_prepare() {
@@ -98,10 +93,6 @@ src_prepare() {
eapply_user
- if ! use bitcoin_policy_rbf; then
- sed -i 's/\(DEFAULT_ENABLE_REPLACEMENT = \)true/\1false/' src/validation.h || die
- fi
-
echo '#!/bin/true' >share/genbuild.sh || die
mkdir -p src/obj || die
echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
diff --git a/net-p2p/bitcoin-qt/metadata.xml b/net-p2p/bitcoin-qt/metadata.xml
index 0e5739a73259..d37cf8037b83 100644
--- a/net-p2p/bitcoin-qt/metadata.xml
+++ b/net-p2p/bitcoin-qt/metadata.xml
@@ -12,7 +12,6 @@
<use>
<flag name="asm">Enable assembly for optimization</flag>
<flag name="bip70">Enable support for the BIP70 payment protocol</flag>
- <flag name="bitcoin_policy_rbf">Replace By Fee policy: Your node will preferentially mine and relay transactions paying the highest fee, regardless of receive order</flag>
<flag name="knots">Build enhanced Bitcoin Knots version, rather than Bitcoin Core</flag>
<flag name="libevent">Use dev-libs/libevent (needed for JSON-RPC, REST, and Tor auto-configuration</flag>
<flag name="qrcode">Enable generation of QR Codes for receiving payments</flag>
diff --git a/net-p2p/bitcoind/bitcoind-0.16.3.ebuild b/net-p2p/bitcoind/bitcoind-0.16.3.ebuild
index 86589b99be5e..585ba9254842 100644
--- a/net-p2p/bitcoind/bitcoind-0.16.3.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.16.3.ebuild
@@ -20,7 +20,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE="+asm +bitcoin_policy_rbf examples knots libressl test upnp +wallet zeromq"
+IUSE="+asm examples knots libressl test upnp +wallet zeromq"
RESTRICT="!test? ( test )"
DEPEND="
@@ -51,14 +51,9 @@ pkg_pretend() {
elog "For more information, see:"
elog "https://bitcoincore.org/en/2018/09/18/release-${PV}/"
fi
- if use bitcoin_policy_rbf; then
- elog "Replace By Fee policy is enabled: Your node will preferentially mine and"
- elog "relay transactions paying the highest fee, regardless of receive order."
- else
- elog "Replace By Fee policy is disabled: Your node will only accept the first"
- elog "transaction seen consuming a conflicting input, regardless of fee"
- elog "offered by later ones."
- fi
+ elog "Replace By Fee policy is now always enabled by default: Your node will"
+ elog "preferentially mine and relay transactions paying the highest fee, regardless"
+ elog "of receive order. To disable RBF, set mempoolreplacement=never in bitcoin.conf"
}
pkg_setup() {
@@ -82,10 +77,6 @@ src_prepare() {
eapply_user
- if ! use bitcoin_policy_rbf; then
- sed -i 's/\(DEFAULT_ENABLE_REPLACEMENT = \)true/\1false/' src/validation.h || die
- fi
-
echo '#!/bin/true' >share/genbuild.sh || die
mkdir -p src/obj || die
echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
diff --git a/net-p2p/bitcoind/metadata.xml b/net-p2p/bitcoind/metadata.xml
index 6283c9d733c0..31bb9103620b 100644
--- a/net-p2p/bitcoind/metadata.xml
+++ b/net-p2p/bitcoind/metadata.xml
@@ -11,7 +11,6 @@
</maintainer>
<use>
<flag name="asm">Enable assembly for optimization</flag>
- <flag name="bitcoin_policy_rbf">Replace By Fee policy: Your node will preferentially mine and relay transactions paying the highest fee, regardless of receive order</flag>
<flag name="knots">Build enhanced Bitcoin Knots version, rather than Bitcoin Core</flag>
<flag name="system-leveldb">Use the system-wide dev-libs/leveldb instead of bundled</flag>
<flag name="upnp">Enable Universal Plug and Play</flag>