summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Efros <powerman-asdf@yandex.ru>2019-03-02 22:45:09 +0200
committerStefan Strogin <steils@gentoo.org>2019-05-28 15:56:51 +0300
commitd75cbc04fc3c8bfa79e6a2d6ef66c27d3a8a650c (patch)
tree773791bf8788ea5c72077d5a5e2501b5e1f4dc30 /net-proxy/3proxy/files
parentsys-libs/e2fsprogs-libs: Removed old. (diff)
downloadgentoo-d75cbc04fc3c8bfa79e6a2d6ef66c27d3a8a650c.tar.gz
gentoo-d75cbc04fc3c8bfa79e6a2d6ef66c27d3a8a650c.tar.bz2
gentoo-d75cbc04fc3c8bfa79e6a2d6ef66c27d3a8a650c.zip
net-proxy/3proxy: Version bump to 0.8.12 and EAPI=7
Signed-off-by: Aleksandr Efros <powerman-asdf@yandex.ru> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11220 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'net-proxy/3proxy/files')
-rw-r--r--net-proxy/3proxy/files/3proxy-0.8.12-gentoo.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-proxy/3proxy/files/3proxy-0.8.12-gentoo.patch b/net-proxy/3proxy/files/3proxy-0.8.12-gentoo.patch
new file mode 100644
index 000000000000..33950f45ceeb
--- /dev/null
+++ b/net-proxy/3proxy/files/3proxy-0.8.12-gentoo.patch
@@ -0,0 +1,49 @@
+diff -uNr a/Makefile.Linux b/Makefile.Linux
+--- a/Makefile.Linux 2018-04-18 22:48:45.000000000 +0300
++++ b/Makefile.Linux 2019-05-26 14:42:38.927811513 +0300
+@@ -8,13 +8,13 @@
+ # library support. Add -DSAFESQL for poorely written ODBC library / drivers.
+
+ BUILDDIR =
+-CC = gcc
++CC ?= gcc
+
+-CFLAGS = -g -O2 -fno-strict-aliasing -c -pthread -DGETHOSTBYNAME_R -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
++CFLAGS += -fno-strict-aliasing -c -pthread -DGETHOSTBYNAME_R -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
+ COUT = -o
+-LN = gcc
++LN ?= gcc
+ DCFLAGS = -fpic
+-LDFLAGS = -O2 -fno-strict-aliasing -pthread
++LDFLAGS += -fno-strict-aliasing -pthread
+ DLFLAGS = -shared
+ DLSUFFICS = .ld.so
+ # -lpthreads may be reuqired on some platforms instead of -pthreads
+@@ -39,12 +39,12 @@
+ include Makefile.inc
+
+ allplugins:
+- @list='$(PLUGINS)'; for p in $$list; do cp Makefile Makefile.var plugins/$$p; cd plugins/$$p ; make ; cd ../.. ; done
++ @list='$(PLUGINS)'; for p in $$list; do cp Makefile Makefile.var plugins/$$p; cd plugins/$$p ; $(MAKE) ; cd ../.. ; done
+
+ DESTDIR =
+-prefix = /usr/local
++prefix =
+ exec_prefix = $(prefix)
+-man_prefix = $(prefix)/share
++man_prefix = $(prefix)/usr/share
+
+ INSTALL = /usr/bin/install
+ INSTALL_BIN = $(INSTALL) -m 755
+diff -uNr a/src/stringtable.c b/src/stringtable.c
+--- a/src/stringtable.c 2018-04-18 22:48:45.000000000 +0300
++++ b/src/stringtable.c 2019-05-26 14:42:07.437810566 +0300
+@@ -38,7 +38,7 @@
+ /* 24 */ NULL,
+ #ifndef TPROXY_CONF
+ #ifndef _WIN32
+-/* 25 */ (unsigned char *)"/usr/local/etc/3proxy/3proxy.cfg",
++/* 25 */ (unsigned char *)"/etc/3proxy/3proxy.cfg",
+ #else
+ /* 25 */ (unsigned char *)"3proxy.cfg",
+ #endif