summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 04:20:19 +0000
committerSam James <sam@gentoo.org>2021-02-27 04:20:19 +0000
commite8c2408f77fc7284593b0260a62b8998438afb51 (patch)
tree00e92d3a43823842a871bc8259908fa1e8eeb55e /sci-astronomy
parentdev-libs/d0_blind_id: Stabilize 1.0 x86, #773184 (diff)
downloadgentoo-e8c2408f77fc7284593b0260a62b8998438afb51.tar.gz
gentoo-e8c2408f77fc7284593b0260a62b8998438afb51.tar.bz2
gentoo-e8c2408f77fc7284593b0260a62b8998438afb51.zip
sci-astronomy/montage: fix gcc 10 (-fno-common) build
Closes: https://bugs.gentoo.org/708396 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/montage/montage-5.0.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/sci-astronomy/montage/montage-5.0.ebuild b/sci-astronomy/montage/montage-5.0.ebuild
index d426c00c3c12..850a2ff98dc4 100644
--- a/sci-astronomy/montage/montage-5.0.ebuild
+++ b/sci-astronomy/montage/montage-5.0.ebuild
@@ -1,20 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs flag-o-matic
MYPN=Montage
-
DESCRIPTION="Toolkit for assembling FITS images into mosaics"
HOMEPAGE="http://montage.ipac.caltech.edu/"
SRC_URI="http://montage.ipac.caltech.edu/download/${MYPN}_v${PV}.tar.gz"
+S="${WORKDIR}/${MYPN}"
LICENSE="BSD GPL-2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
SLOT="0"
-
IUSE="doc mpi"
RDEPEND="
@@ -31,10 +30,9 @@ PATCHES=(
"${FILESDIR}"/${PN}-5.0-fix_freetype_incude.patch
)
-S="${WORKDIR}/${MYPN}"
-
src_prepare() {
default
+
sed -e '/cfitsio/d' \
-e '/wcssubs/d' \
-e '/jpeg/d' \
@@ -43,6 +41,9 @@ src_prepare() {
tc-export CC AR
+ # bug #708396
+ append-cflags -fcommon
+
find . -name Makefile\* | xargs sed -i \
-e "/^CC.*=/s:\(gcc\|cc\):$(tc-getCC):g" \
-e "/^CFLAGS.*=/s:-g:${CFLAGS} $($(tc-getPKG_CONFIG) --cflags wcstools):g" \