summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-14 23:30:19 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-14 23:30:19 +0200
commit2761842aa02a4b9f086aa967463d1112f50c2a26 (patch)
tree9567f52526eb62a578fe2bcef75171c461b6cb04 /sci-chemistry/gromacs
parentmedia-libs/libsoundtouch: [QA] tc-has-openmp → tc-check-openmp (diff)
downloadgentoo-2761842aa02a4b9f086aa967463d1112f50c2a26.tar.gz
gentoo-2761842aa02a4b9f086aa967463d1112f50c2a26.tar.bz2
gentoo-2761842aa02a4b9f086aa967463d1112f50c2a26.zip
sci-chemistry/gromacs: [QA] tc-has-openmp → tc-check-openmp
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-chemistry/gromacs')
-rw-r--r--sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild8
-rw-r--r--sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild8
-rw-r--r--sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild8
-rw-r--r--sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2020.7.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.5.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.9999.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.1.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.9999.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-2022.ebuild5
-rw-r--r--sci-chemistry/gromacs/gromacs-9999.ebuild5
12 files changed, 33 insertions, 36 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild b/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild
index 4423a8eed2ad..fb79ed729b5a 100644
--- a/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild
@@ -58,9 +58,11 @@ RESTRICT="!test? ( test )"
S="${WORKDIR}/${PN}-${PV/_/-}"
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {
diff --git a/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild b/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
index cacbc3eef174..b04308aaa907 100644
--- a/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2019.6-r1.ebuild
@@ -61,9 +61,11 @@ RESTRICT="!test? ( test )"
S="${WORKDIR}/${PN}-${PV/_/-}"
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {
diff --git a/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild b/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild
index b01b57f54196..71a5399a8a70 100644
--- a/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild
@@ -63,9 +63,11 @@ S="${WORKDIR}/${PN}-${PV/_/-}"
PATCHES=( "${FILESDIR}/${P}-missing-include.patch" )
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {
diff --git a/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild b/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild
index cd8f59f82ed7..3d38fc4523bb 100644
--- a/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2020.4-r1.ebuild
@@ -90,12 +90,11 @@ fi
PATCHES=( "${FILESDIR}/${PN}-2020-pytest.patch" )
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
python-single-r1_pkg_setup
}
diff --git a/sci-chemistry/gromacs/gromacs-2020.7.ebuild b/sci-chemistry/gromacs/gromacs-2020.7.ebuild
index b5211f6374ac..2e38306eb66f 100644
--- a/sci-chemistry/gromacs/gromacs-2020.7.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2020.7.ebuild
@@ -90,12 +90,11 @@ fi
PATCHES=( "${FILESDIR}/${PN}-2020-pytest.patch" )
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
python-single-r1_pkg_setup
}
diff --git a/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild b/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
index 9ebdeb01146c..1ea7d0f255b7 100644
--- a/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.3-r1.ebuild
@@ -90,12 +90,11 @@ if [[ ${PV} != *9999 ]]; then
fi
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
python-single-r1_pkg_setup
}
diff --git a/sci-chemistry/gromacs/gromacs-2021.5.ebuild b/sci-chemistry/gromacs/gromacs-2021.5.ebuild
index abf5ed8ec5ef..b797cea596be 100644
--- a/sci-chemistry/gromacs/gromacs-2021.5.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.5.ebuild
@@ -90,12 +90,11 @@ if [[ ${PV} != *9999 ]]; then
fi
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
python-single-r1_pkg_setup
}
diff --git a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
index d9c7e8a5269e..8e32fc1644e1 100644
--- a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
@@ -88,12 +88,11 @@ if [[ ${PV} != *9999 ]]; then
fi
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
python-single-r1_pkg_setup
}
diff --git a/sci-chemistry/gromacs/gromacs-2022.1.ebuild b/sci-chemistry/gromacs/gromacs-2022.1.ebuild
index 338c03cc2a11..80afa36142da 100644
--- a/sci-chemistry/gromacs/gromacs-2022.1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.1.ebuild
@@ -87,12 +87,11 @@ if [[ ${PV} != *9999 ]]; then
fi
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
python-single-r1_pkg_setup
}
diff --git a/sci-chemistry/gromacs/gromacs-2022.9999.ebuild b/sci-chemistry/gromacs/gromacs-2022.9999.ebuild
index 655c647a73dd..101a76d94cf9 100644
--- a/sci-chemistry/gromacs/gromacs-2022.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.9999.ebuild
@@ -85,12 +85,11 @@ if [[ ${PV} != *9999 ]]; then
fi
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
python-single-r1_pkg_setup
}
diff --git a/sci-chemistry/gromacs/gromacs-2022.ebuild b/sci-chemistry/gromacs/gromacs-2022.ebuild
index 338c03cc2a11..80afa36142da 100644
--- a/sci-chemistry/gromacs/gromacs-2022.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2022.ebuild
@@ -87,12 +87,11 @@ if [[ ${PV} != *9999 ]]; then
fi
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
python-single-r1_pkg_setup
}
diff --git a/sci-chemistry/gromacs/gromacs-9999.ebuild b/sci-chemistry/gromacs/gromacs-9999.ebuild
index 655c647a73dd..101a76d94cf9 100644
--- a/sci-chemistry/gromacs/gromacs-9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-9999.ebuild
@@ -85,12 +85,11 @@ if [[ ${PV} != *9999 ]]; then
fi
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
python-single-r1_pkg_setup
}