summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:13:32 +0200
committerMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:25:46 +0200
commitef4a4ee8493e72ce551b24dd26d4fa6fb55c4b44 (patch)
tree9b5d8cec40f687ae02ab6f2fd8eeb3619fc29ba0 /sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-9999.ebuild
parentsci-geosciences/opencpn-plugin-launcher: bump version, add live version (diff)
downloadgentoo-ef4a4ee8493e72ce551b24dd26d4fa6fb55c4b44.tar.gz
gentoo-ef4a4ee8493e72ce551b24dd26d4fa6fb55c4b44.tar.bz2
gentoo-ef4a4ee8493e72ce551b24dd26d4fa6fb55c4b44.zip
sci-geosciences/opencpn-plugin-logbookkonni: bump version, add live version
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-9999.ebuild')
-rw-r--r--sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-9999.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-9999.ebuild b/sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-9999.ebuild
new file mode 100644
index 000000000000..2add5874e0fc
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="LogbookKonni-1.2"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/delatbabel/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/delatbabel/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/delatbabel/${MY_PN}/releases/download/v${PV}/LogbookKonni_Layouts.zip -> ${P}_Layouts.zip
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Logbook Plugin for OpenCPN"
+HOMEPAGE="https://github.com/delatbabel/LogbookKonni-1.2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="
+ app-arch/zip
+ ${RDEPEND}
+"
+
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}
+
+src_install() {
+ # install layouts as zip
+ cmake-utils_src_install
+ cd "$WORKDIR"
+ zip -r "$D"/usr/share/opencpn/plugins/logbookkonni_pi/data/LogbookKonni_Layouts.zip Clouds HTMLLayouts ODTLayouts
+}
+
+pkg_postinst() {
+ elog "Installation of logbook layouts"
+ elog "*******************************"
+ elog ""
+ elog "The default layouts zip file has been installed to:"
+ elog "/usr/share/opencpn/plugins/logbookkonni_pi/data/LogbookKonni_Layouts.zip"
+ elog ""
+ elog "After starting OpenCPN, go to Options->Plugins->Logbook->Settings,"
+ elog "click the install button and choose the above mentioned zip file"
+ elog ""
+}
+