summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:13:32 +0200
committerMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:25:46 +0200
commitef4a4ee8493e72ce551b24dd26d4fa6fb55c4b44 (patch)
tree9b5d8cec40f687ae02ab6f2fd8eeb3619fc29ba0 /sci-geosciences
parentsci-geosciences/opencpn-plugin-launcher: bump version, add live version (diff)
downloadgentoo-ef4a4ee8493e72ce551b24dd26d4fa6fb55c4b44.tar.gz
gentoo-ef4a4ee8493e72ce551b24dd26d4fa6fb55c4b44.tar.bz2
gentoo-ef4a4ee8493e72ce551b24dd26d4fa6fb55c4b44.zip
sci-geosciences/opencpn-plugin-logbookkonni: bump version, add live version
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/opencpn-plugin-logbookkonni/Manifest2
-rw-r--r--sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-1.3002.ebuild63
-rw-r--r--sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-9999.ebuild63
3 files changed, 128 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-logbookkonni/Manifest b/sci-geosciences/opencpn-plugin-logbookkonni/Manifest
index 9c9f0d95012b..c512747ee284 100644
--- a/sci-geosciences/opencpn-plugin-logbookkonni/Manifest
+++ b/sci-geosciences/opencpn-plugin-logbookkonni/Manifest
@@ -1,2 +1,4 @@
DIST opencpn-plugin-logbookkonni-1.2018.tar.gz 3768720 SHA256 aa7967cf2a7993968f8842b9adf220a57b065afd4be3899cca0771d780697792 SHA512 5435b639bc635b5bbe87c92306d93dee7897ce3e5c6bb383aa228ad90127d2ab1f2a5e871a68abfec30ff2a327c4c21c023a61ccdad445a25bbb8a44fec19d41 WHIRLPOOL ed6bd46ca2b7dd637f0da7bcfd1c6457f10cd2b0cb9a00bf6babd05271ada7b31d23360a5f57ffccdd9d1d49dfbf135dea2c5413fd219d30a0d4d175b3f5f823
DIST opencpn-plugin-logbookkonni-1.2018_Layouts.zip 1722887 SHA256 9b31cbf893069ba7037a7eca569a46e52b773439f44eedb7f4202b908817d48e SHA512 5ce35b3f4c14a432b472db496e8a5dc46fbcd5b0b404c085d6d024f2f383ae9e3767ccdf750177f102ec19a7a0d61a1ab331fef701bf29f8c851305a73923296 WHIRLPOOL bb4f49322f27b7fe0804cf035ddcb87fcca6ade5b968ce703f74f7498e58fc8146ab20839a7525f92ce92fc5151b75a45fcddf54e99c202baa8711f89e91ffb2
+DIST opencpn-plugin-logbookkonni-1.3002.tar.gz 3810133 SHA256 8566c68ffa748529f6b3dbc71c618e4e9b6a0afcee0dfcaaf0b2e77e44232a79 SHA512 a539e8d01f9e81f859826477c1abbdafeacc1bd0a1e734777698eb471ddf0a1356bcd321b4b3aa27f9593e0d412e52fb8791248a0dfbc20daa7c9214152e8030 WHIRLPOOL 69a6d3f59271ac889f99408b3dcc92f08e8ff8a74221cbfcbdccd8a7cefdd150fdb1594a98acd64fdd0e87c750945401ffb7f07e84c54a10a9995534fffe8614
+DIST opencpn-plugin-logbookkonni-1.3002_Layouts.zip 1722887 SHA256 6c2ae65cb5cab258dc4e2015b82a5a740a8751ffe74233eb0da36c7b5c24c453 SHA512 f493d9af822a960f3b9a5d557d46b73e89c8179bfbc4d260d133c972e22d4ce5753e64b2d8ced321589a11a0a32efe1c34b574ed850af0673768896cdbb3d9c5 WHIRLPOOL 92d583b1cc19e44d3036a597b0ad72e1a80eb962ccfdbba386966ea5f625cdacb467219efebbc1106feda7ef300e6cbce9415371b23e38a49fa8435db25c3a0f
diff --git a/sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-1.3002.ebuild b/sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-1.3002.ebuild
new file mode 100644
index 000000000000..2add5874e0fc
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-1.3002.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="LogbookKonni-1.2"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/delatbabel/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/delatbabel/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/delatbabel/${MY_PN}/releases/download/v${PV}/LogbookKonni_Layouts.zip -> ${P}_Layouts.zip
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Logbook Plugin for OpenCPN"
+HOMEPAGE="https://github.com/delatbabel/LogbookKonni-1.2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="
+ app-arch/zip
+ ${RDEPEND}
+"
+
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}
+
+src_install() {
+ # install layouts as zip
+ cmake-utils_src_install
+ cd "$WORKDIR"
+ zip -r "$D"/usr/share/opencpn/plugins/logbookkonni_pi/data/LogbookKonni_Layouts.zip Clouds HTMLLayouts ODTLayouts
+}
+
+pkg_postinst() {
+ elog "Installation of logbook layouts"
+ elog "*******************************"
+ elog ""
+ elog "The default layouts zip file has been installed to:"
+ elog "/usr/share/opencpn/plugins/logbookkonni_pi/data/LogbookKonni_Layouts.zip"
+ elog ""
+ elog "After starting OpenCPN, go to Options->Plugins->Logbook->Settings,"
+ elog "click the install button and choose the above mentioned zip file"
+ elog ""
+}
+
diff --git a/sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-9999.ebuild b/sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-9999.ebuild
new file mode 100644
index 000000000000..2add5874e0fc
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-logbookkonni/opencpn-plugin-logbookkonni-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="LogbookKonni-1.2"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/delatbabel/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/delatbabel/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/delatbabel/${MY_PN}/releases/download/v${PV}/LogbookKonni_Layouts.zip -> ${P}_Layouts.zip
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Logbook Plugin for OpenCPN"
+HOMEPAGE="https://github.com/delatbabel/LogbookKonni-1.2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="
+ app-arch/zip
+ ${RDEPEND}
+"
+
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}
+
+src_install() {
+ # install layouts as zip
+ cmake-utils_src_install
+ cd "$WORKDIR"
+ zip -r "$D"/usr/share/opencpn/plugins/logbookkonni_pi/data/LogbookKonni_Layouts.zip Clouds HTMLLayouts ODTLayouts
+}
+
+pkg_postinst() {
+ elog "Installation of logbook layouts"
+ elog "*******************************"
+ elog ""
+ elog "The default layouts zip file has been installed to:"
+ elog "/usr/share/opencpn/plugins/logbookkonni_pi/data/LogbookKonni_Layouts.zip"
+ elog ""
+ elog "After starting OpenCPN, go to Options->Plugins->Logbook->Settings,"
+ elog "click the install button and choose the above mentioned zip file"
+ elog ""
+}
+