summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-18 20:47:40 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-18 21:00:06 -0500
commit19421f254633d6882cb9558e89bddad71f474c0a (patch)
tree8cfbbe243e007931129c9f0954c2c4ba828071b6 /sci-geosciences
parentsys-apps/gnome-disk-utility: Version bump to 41.0 (diff)
downloadgentoo-19421f254633d6882cb9558e89bddad71f474c0a.tar.gz
gentoo-19421f254633d6882cb9558e89bddad71f474c0a.tar.bz2
gentoo-19421f254633d6882cb9558e89bddad71f474c0a.zip
sci-geosciences/gnome-maps: Version bump to 41.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-41.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index 12c14724b243..64545e809e32 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,2 +1,3 @@
DIST gnome-maps-40.5.tar.xz 3542648 BLAKE2B bbc45882e314667def29b8d7491afba2e1649ef62a6898a58b4afd93bd26537af73588d9cecd0ed06fc53c8083ade6d33f468b4a51481886d30abdc13558be80 SHA512 1d53dda1b96fb5a6db4152380f9136f2e66cbc0062434254cc0b47e999c19dfcbde6bc1d6bc787474eab83b29293a1e207cf41b177f7cd01b29ccb15a6628d15
DIST gnome-maps-41.1.tar.xz 2187384 BLAKE2B 792ada987c513118411233b477373db015e55b5c4da2405d40f69833fbce3d0fdfec4c194fdfa762d5642039c4965db9a606d6206e8c52b16a4f7c26ae9b54ab SHA512 ff750c009c0409bdf87a08b2a89296f5f214f8fa294c7470e99841fc6f155ae14cf9bfd388a65231e03c4c4fdbe5606c90b2bf5897e756a1699a19782f89a5db
+DIST gnome-maps-41.2.tar.xz 2187460 BLAKE2B 83f93f9cf371e4275cb73e9a847be6400a4f736fe605266a1f371bc03af13b37af3bae04d5d0a7dbddd8605c099af92030ed8dec555f1f1b59339c9f907b3b21 SHA512 b0f167797986224d5b51df4be44731409241935513f6863ef844121b8b29829ed6ba1e37a2478b93e79dab5f9825e1632ef74f576f37990c9f9779b8de24cddc
diff --git a/sci-geosciences/gnome-maps/gnome-maps-41.2.ebuild b/sci-geosciences/gnome-maps/gnome-maps-41.2.ebuild
new file mode 100644
index 000000000000..5ec15782805f
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-41.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+# Pure introspection dependencies found by grepping imports.gi in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ x11-libs/pango[introspection]
+ >=dev-libs/gjs-1.66.0
+ >=dev-libs/gobject-introspection-0.10.1:=
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libhandy-0.84:1=
+ >=dev-libs/libgee-0.16:0.8[introspection]
+ >=dev-libs/folks-0.10:=
+ >=sci-geosciences/geocode-glib-3.15.2[introspection]
+ >=media-libs/libchamplain-0.12.14:0.12[gtk,introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.7.90:0.7[introspection]
+
+ app-crypt/libsecret[introspection]
+ dev-libs/libgweather[introspection]
+ media-libs/clutter-gtk:1.0[introspection]
+ media-libs/clutter:1.0[introspection]
+ net-libs/gnome-online-accounts[introspection]
+ net-libs/libgfbgraph[introspection]
+ net-libs/libsoup:2.4[introspection]
+ net-libs/webkit-gtk:4[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}