summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2018-03-17 00:24:57 +0100
committerMarc Schiffbauer <mschiff@gentoo.org>2018-03-17 00:46:01 +0100
commitcbeaa41174db4d3123654255f66ab8398d0cf415 (patch)
tree073987dbc8a9fb7acb0f9c7932ff36fe0041054c /sci-geosciences
parentsci-geosciences/opencpn-plugin-statusbar: added snapshot version (diff)
downloadgentoo-cbeaa41174db4d3123654255f66ab8398d0cf415.tar.gz
gentoo-cbeaa41174db4d3123654255f66ab8398d0cf415.tar.bz2
gentoo-cbeaa41174db4d3123654255f66ab8398d0cf415.zip
sci-geosciences/opencpn-plugin-weatherfax: added snapshot version
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/opencpn-plugin-weatherfax/Manifest1
-rw-r--r--sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-1.3.20180316.ebuild37
-rw-r--r--sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild4
3 files changed, 40 insertions, 2 deletions
diff --git a/sci-geosciences/opencpn-plugin-weatherfax/Manifest b/sci-geosciences/opencpn-plugin-weatherfax/Manifest
index f450e9d4af17..56a1278d8979 100644
--- a/sci-geosciences/opencpn-plugin-weatherfax/Manifest
+++ b/sci-geosciences/opencpn-plugin-weatherfax/Manifest
@@ -1 +1,2 @@
+DIST opencpn-plugin-weatherfax-1.3.20180316.tar.gz 585747 BLAKE2B f81de2da49cd16be62b4fc64e025626a3b7470563db32293803275c0a682b1eff5c85dead9d846e6b69362aa6faaf370f707ab7dab0db981a431bf8872a66430 SHA512 effa3fc2c348bf5a0d70dcfee8a4643f8cba51e5177e40affc50e2d85bffcb2c89c067a57eadb18834900691214b2b1ee17760a8b525cf12da4c7a3e6970daf0
DIST opencpn-plugin-weatherfax-1.3.tar.gz 505937 BLAKE2B be7ba09bcda55e9806239553c6e0f99ddee7cc5848de9a3203fb061543babfb15624961775e7b702348980f3523865b863526739703b7b32122b272add23f627 SHA512 54fe8f25a21d373ab00bcd5d77950532bb06c5324cdd1082e4109cad8a33b714ed0d7cd8ebe7e9540e5e10039b2a0fe23b4b88df0244f1e84b852111807ad6e4
diff --git a/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-1.3.20180316.ebuild b/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-1.3.20180316.ebuild
new file mode 100644
index 000000000000..a9bec2036741
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-1.3.20180316.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="weatherfax_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/seandepagnier/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/mschiff/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Weatherfax Plugin for OpenCPN"
+HOMEPAGE="https://github.com/seandepagnier/weatherfax_pi"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}
diff --git a/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild b/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild
index 2551edd07cf2..a9bec2036741 100644
--- a/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild
+++ b/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -11,7 +11,7 @@ if [[ ${PV} == "9999" ]] ; then
KEYWORDS=""
else
SRC_URI="
- https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/mschiff/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
"
inherit cmake-utils wxwidgets
KEYWORDS="~amd64 ~x86"