summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-01-27 11:47:20 +0100
committerJakov Smolić <jsmolic@gentoo.org>2023-01-27 12:07:04 +0100
commit4d47e5c5c59725cdeab3b04622ffde1baa9de073 (patch)
tree6afe71218c1d6d8edcaffc570a68f4dbb6e7667e /sci-libs
parentdev-db/mysql-super-smack: treeclean (diff)
downloadgentoo-4d47e5c5c59725cdeab3b04622ffde1baa9de073.tar.gz
gentoo-4d47e5c5c59725cdeab3b04622ffde1baa9de073.tar.bz2
gentoo-4d47e5c5c59725cdeab3b04622ffde1baa9de073.zip
sci-libs/libmems: treeclean
Closes: https://bugs.gentoo.org/677558 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libmems/Manifest1
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-boost-1.62-type-traits.patch15
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-boost.patch120
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-broken-constness.patch24
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-build.patch29
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-fix-c++14.patch18
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-format-security.patch16
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-gcc-4.7.patch71
-rw-r--r--sci-libs/libmems/libmems-1.6_p1-r3.ebuild59
-rw-r--r--sci-libs/libmems/libmems-9999.ebuild31
-rw-r--r--sci-libs/libmems/metadata.xml8
11 files changed, 0 insertions, 392 deletions
diff --git a/sci-libs/libmems/Manifest b/sci-libs/libmems/Manifest
deleted file mode 100644
index b82404e2854c..000000000000
--- a/sci-libs/libmems/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libmems-1.6_p1.tar.xz 226628 BLAKE2B 6410f8e0dc40855ce7a09127f4aa70face9007d5edbe424d595d8607a341137d8892008c5e6d9a37cbed05158d04b7d5a5ff5f02ba441b90cb30cbea2d21c88a SHA512 c6336f69b767bba010617deb2de9bb8fbbbaf516de3b1d293b062c76c6a763166080badd730938c6d849602d64a968edb6d4622b5d3e7ea7a6d8bc38164d3d73
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-boost-1.62-type-traits.patch b/sci-libs/libmems/files/libmems-1.6_p1-boost-1.62-type-traits.patch
deleted file mode 100644
index 609d0de0c478..000000000000
--- a/sci-libs/libmems/files/libmems-1.6_p1-boost-1.62-type-traits.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Shuffle around Boost type_traits, which otherwise causes issues with boost 1.62.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=595986
-
---- a/libMems/AbstractMatch.h
-+++ b/libMems/AbstractMatch.h
-@@ -16,8 +16,7 @@
- #include "libGenome/gnClone.h"
- #include <vector>
- #include <algorithm>
--#include <boost/type_traits/remove_pointer.hpp>
--#include <boost/type_traits/add_pointer.hpp>
-+#include <boost/type_traits.hpp>
- #include <boost/dynamic_bitset.hpp>
- #include <libMems/SlotAllocator.h>
- #include <libMems/configuration.h>
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-boost.patch b/sci-libs/libmems/files/libmems-1.6_p1-boost.patch
deleted file mode 100644
index 4f0c775a6d9c..000000000000
--- a/sci-libs/libmems/files/libmems-1.6_p1-boost.patch
+++ /dev/null
@@ -1,120 +0,0 @@
- libMems/Backbone.cpp | 2 +-
- libMems/Files.h | 64 +++++++++++++++++++++---------------------
- libMems/ProgressiveAligner.cpp | 2 +-
- 3 files changed, 34 insertions(+), 34 deletions(-)
-
-diff --git a/libMems/Backbone.cpp b/libMems/Backbone.cpp
-index 86698a9..0025cd8 100644
---- a/libMems/Backbone.cpp
-+++ b/libMems/Backbone.cpp
-@@ -15,7 +15,7 @@
- #include "libMems/Islands.h"
- #include "libMems/CompactGappedAlignment.h"
-
--#include <boost/property_map.hpp>
-+#include <boost/property_map/property_map.hpp>
- #include <boost/graph/graph_traits.hpp>
- #include <boost/graph/adjacency_list.hpp>
- #include <boost/graph/topological_sort.hpp>
-diff --git a/libMems/Files.h b/libMems/Files.h
-index 8d6e9be..8191065 100644
---- a/libMems/Files.h
-+++ b/libMems/Files.h
-@@ -22,44 +22,44 @@
-
- #include "boost/filesystem/operations.hpp"
- #include "boost/filesystem/exception.hpp"
--#include "boost/algorithm/string.hpp"
-+#include "boost/algorithm/string.hpp"
- #include <string>
- #include <sstream>
- #include <iostream>
- #include <iomanip>
-
-
--/**
-- * Register a file name to be deleted before the process exits
-- * When passed an empty string, it does not add to the list of files to delete
-- * @param fname The name of a file to delete, empty strings are ignored
-- * @return A vector of file names registered for deletion
-- */
--std::vector< std::string >& registerFileToDelete( std::string fname = "" );
--
--inline
--std::vector< std::string >& registerFileToDelete( std::string fname ) {
-- // since this vector is needed when atexit() is called we allocate it
-- // on the heap so its destructor won't get called
-- static std::vector< std::string >* files = new std::vector< std::string >();
--#pragma omp critical
--{
-- if( fname != "" )
-- files->push_back( fname );
--}
-- return *files;
--}
-+/**
-+ * Register a file name to be deleted before the process exits
-+ * When passed an empty string, it does not add to the list of files to delete
-+ * @param fname The name of a file to delete, empty strings are ignored
-+ * @return A vector of file names registered for deletion
-+ */
-+std::vector< std::string >& registerFileToDelete( std::string fname = "" );
-
--void deleteRegisteredFiles();
--inline
--void deleteRegisteredFiles() {
-- // don't be a slob, clean up after yourself:
-- // delete any files that are laying around
-- std::vector< std::string >& del_files = registerFileToDelete();
-- for( int fileI = 0; fileI < del_files.size(); fileI++ )
-- boost::filesystem::remove( del_files[ fileI ] );
-- del_files.clear(); // clear the deleted files from the list
--}
-+inline
-+std::vector< std::string >& registerFileToDelete( std::string fname ) {
-+ // since this vector is needed when atexit() is called we allocate it
-+ // on the heap so its destructor won't get called
-+ static std::vector< std::string >* files = new std::vector< std::string >();
-+#pragma omp critical
-+{
-+ if( fname != "" )
-+ files->push_back( fname );
-+}
-+ return *files;
-+}
-+
-+void deleteRegisteredFiles();
-+inline
-+void deleteRegisteredFiles() {
-+ // don't be a slob, clean up after yourself:
-+ // delete any files that are laying around
-+ std::vector< std::string >& del_files = registerFileToDelete();
-+ for( int fileI = 0; fileI < del_files.size(); fileI++ )
-+ boost::filesystem::remove( del_files[ fileI ] );
-+ del_files.clear(); // clear the deleted files from the list
-+}
-
-
- /**
-@@ -80,7 +80,7 @@ std::string CreateTempFileName(const std::string& prefix)
- #endif
- boost::filesystem::path path( prefix );
- dir = path.branch_path().string();
-- name = path.leaf();
-+ name = path.filename().string();
- if( name == "/" )
- {
- dir += name;
-diff --git a/libMems/ProgressiveAligner.cpp b/libMems/ProgressiveAligner.cpp
-index 3be5fe0..5667a9e 100644
---- a/libMems/ProgressiveAligner.cpp
-+++ b/libMems/ProgressiveAligner.cpp
-@@ -27,7 +27,7 @@
-
- #include <boost/dynamic_bitset.hpp>
- #include <boost/tuple/tuple.hpp>
--#include <boost/property_map.hpp>
-+#include <boost/property_map/property_map.hpp>
- #include <boost/graph/graph_traits.hpp>
- #include <boost/graph/adjacency_list.hpp>
- #include <boost/graph/johnson_all_pairs_shortest.hpp>
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-broken-constness.patch b/sci-libs/libmems/files/libmems-1.6_p1-broken-constness.patch
deleted file mode 100644
index 0bd922c9e111..000000000000
--- a/sci-libs/libmems/files/libmems-1.6_p1-broken-constness.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Fix bug 529770 caused by non-const copy constructor.
-
---- libmems-1.6_p1/libMems/Aligner.cpp
-+++ libmems-1.6_p1/libMems/Aligner.cpp
-@@ -939,7 +939,7 @@
- MatchLeftEndComparator( unsigned seq = 0 ){
- m_seq = seq;
- }
-- MatchLeftEndComparator( MatchLeftEndComparator& msc ){
-+ MatchLeftEndComparator( const MatchLeftEndComparator& msc ){
- m_seq = msc.m_seq;
- }
- // TODO?? make this do a wraparound comparison if all is equal?
---- libmems-1.6_p1/libMems/Aligner.h
-+++ libmems-1.6_p1/libMems/Aligner.h
-@@ -49,7 +49,7 @@
- LabeledMemComparator( uint seq ){
- m_seq = seq;
- }
-- LabeledMemComparator( LabeledMemComparator& lmc ){
-+ LabeledMemComparator( const LabeledMemComparator& lmc ){
- m_seq = lmc.m_seq;
- }
- boolean operator()(const LabeledMem& a, const LabeledMem& b) const{
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-build.patch b/sci-libs/libmems/files/libmems-1.6_p1-build.patch
deleted file mode 100644
index 04d5dd9c82ac..000000000000
--- a/sci-libs/libmems/files/libmems-1.6_p1-build.patch
+++ /dev/null
@@ -1,29 +0,0 @@
- libMems/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libMems/Makefile.am b/libMems/Makefile.am
-index 6101f71..d66053d 100644
---- a/libMems/Makefile.am
-+++ b/libMems/Makefile.am
-@@ -2,10 +2,10 @@
- if DEBUG
- D_CXXFLAGS = -Wall -g -D__GNDEBUG__
- endif
--OPTIMIZATION = -O2 -Wall -funroll-loops -fomit-frame-pointer -ftree-vectorize
- AM_CFLAGS = $(OPTIMIZATION) @DEPS_CFLAGS@ -DUSE_POSIX_AIO @OPENMP_CFLAGS@
- AM_CXXFLAGS = $(OPTIMIZATION) @DEPS_CFLAGS@ @BOOST_CPPFLAGS@ $(D_CXXFLAGS) @EXTRA_CXX_FLAGS@ @OPENMP_CXXFLAGS@
- AM_LDFLAGS = $(OPTIMIZATION)
-+AM_CPPFLAGS=-I$(top_srcdir)
-
- LIBMEMS_H = \
- RepeatHash.h MatchHashEntry.h \
---- a/libMems/dmSML/util.c
-+++ b/libMems/dmSML/util.c
-@@ -2,6 +2,7 @@
- #include "config.h"
- #endif
-
-+#include <stdlib.h>
- #include <stdio.h>
- #include "libMems/dmSML/util.h"
-
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-fix-c++14.patch b/sci-libs/libmems/files/libmems-1.6_p1-fix-c++14.patch
deleted file mode 100644
index bde8efeb4c9c..000000000000
--- a/sci-libs/libmems/files/libmems-1.6_p1-fix-c++14.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Description: Correct compilation with g++-6
-Author: Gert Wollny <gw.fossdev@gmail.com>
-Bug-Debian: https://bugs.debian.org/811870
-Forwarded: yes
-Bug: https://sourceforge.net/p/mauve/bugs/46/
-Last-Update: 2016-06-30
-
---- a/libMems/ProgressiveAligner.cpp
-+++ b/libMems/ProgressiveAligner.cpp
-@@ -1599,7 +1599,7 @@
- c.SetLeftEnd(child_1, ancestral_matches[mI]->LeftEnd(1));
- c.SetOrientation(child_1, ancestral_matches[mI]->Orientation(1));
- c.SetLength(ancestral_matches[mI]->Length(1), child_1);
-- cga_list.push_back(make_tuple(c.Copy(), &bs[mI], ancestral_matches[mI]));
-+ cga_list.push_back(boost::tuples::make_tuple(c.Copy(), &bs[mI], ancestral_matches[mI]));
- }
-
- stack<node_id_t> node_stack;
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-format-security.patch b/sci-libs/libmems/files/libmems-1.6_p1-format-security.patch
deleted file mode 100644
index 3ad3da2a8d80..000000000000
--- a/sci-libs/libmems/files/libmems-1.6_p1-format-security.patch
+++ /dev/null
@@ -1,16 +0,0 @@
- libMems/dmSML/dmsort.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libMems/dmSML/dmsort.c b/libMems/dmSML/dmsort.c
-index 4c99215..2cbfa7e 100644
---- a/libMems/dmSML/dmsort.c
-+++ b/libMems/dmSML/dmsort.c
-@@ -825,7 +825,7 @@ int InitdmSML( long working_mb, long buffer_size, const char* input_filename, co
- if ( fgets(buf, sizeof(buf), fp) )
- {
- sscanf(buf, "MemTotal: %ld kB", &memTotal);
-- fprintf( stderr, buf );
-+ fprintf( stderr, "%s", buf );
- }
- fclose(fp);
- // allocate about 6/10 of physical memory
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-gcc-4.7.patch b/sci-libs/libmems/files/libmems-1.6_p1-gcc-4.7.patch
deleted file mode 100644
index ec620ebb35aa..000000000000
--- a/sci-libs/libmems/files/libmems-1.6_p1-gcc-4.7.patch
+++ /dev/null
@@ -1,71 +0,0 @@
- libMems/CompactGappedAlignment.h | 36 ++++++++++++++++++------------------
- 1 file changed, 18 insertions(+), 18 deletions(-)
-
-diff --git a/libMems/CompactGappedAlignment.h b/libMems/CompactGappedAlignment.h
-index bf78477..942d4aa 100644
---- a/libMems/CompactGappedAlignment.h
-+++ b/libMems/CompactGappedAlignment.h
-@@ -13,7 +13,7 @@
- #include "config.h"
- #endif
-
--#include "libGenome/gnDebug.h"
-+#include "libGenome/gnDebug.h"
- #include "libGenome/gnFilter.h"
- #include "libGenome/gnSequence.h"
- #include "libMems/SparseAbstractMatch.h"
-@@ -103,15 +103,15 @@ public:
- /** Eliminates any columns that contain only gap characters */
- void CondenseGapColumns();
-
-- void swap( CompactGappedAlignment& other ){ swap(&other); }
--
--protected:
-- // for use by derived classes in order to swap contents
-- void swap( CompactGappedAlignment* other ){
-- std::swap( align_matrix, other->align_matrix );
-- std::swap( bcount, other->bcount );
-- BaseType::swap( other );
-- }
-+ void swap( CompactGappedAlignment& other ){ swap(&other); }
-+
-+protected:
-+ // for use by derived classes in order to swap contents
-+ void swap( CompactGappedAlignment* other ){
-+ std::swap( align_matrix, other->align_matrix );
-+ std::swap( bcount, other->bcount );
-+ BaseType::swap( other );
-+ }
-
- std::vector< bitset_t > align_matrix; /**< aligned positions have true values, gaps are false */
- std::vector< std::vector< size_t > > bcount;
-@@ -572,7 +572,7 @@ void CompactGappedAlignment<BaseType>::CropEnd(gnSeqI crop_amount){
- this->SetStart(i, 0);
- }
- }
-- SetAlignmentLength( this->AlignmentLength() - crop_amount );
-+ this->SetAlignmentLength( this->AlignmentLength() - crop_amount );
- this->create_bitcount();
- if( !this->validate() )
- std::cerr << "CropEnd error\n";
-@@ -806,13 +806,13 @@ void CompactGappedAlignment<BaseType>::CondenseGapColumns()
-
- }
-
--namespace std {
--template<> inline
--void swap( mems::CompactGappedAlignment<>& a, mems::CompactGappedAlignment<>& b )
--{
-- a.swap(b);
--}
--}
-+namespace std {
-+template<> inline
-+void swap( mems::CompactGappedAlignment<>& a, mems::CompactGappedAlignment<>& b )
-+{
-+ a.swap(b);
-+}
-+}
-
-
- #endif // __CompactGappedAlignment_h__
diff --git a/sci-libs/libmems/libmems-1.6_p1-r3.ebuild b/sci-libs/libmems/libmems-1.6_p1-r3.ebuild
deleted file mode 100644
index 513fd1f3af61..000000000000
--- a/sci-libs/libmems/libmems-1.6_p1-r3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="Library for sci-biology/mauve"
-HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
-SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
-
-SLOT="0"
-LICENSE="GPL-2"
-IUSE="doc static-libs"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-libs/boost:=
- sci-libs/libgenome
- sci-libs/libmuscle"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-build.patch
- "${FILESDIR}"/${P}-boost.patch
- "${FILESDIR}"/${P}-gcc-4.7.patch
- "${FILESDIR}"/${P}-broken-constness.patch
- "${FILESDIR}"/${P}-format-security.patch
- "${FILESDIR}"/${P}-fix-c++14.patch
- "${FILESDIR}"/${P}-boost-1.62-type-traits.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --enable-shared \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- default
-
- if use doc; then
- doxygen doxygen.am || die
- HTML_DOCS+=( html/. )
- fi
-}
-
-src_install() {
- default
-
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
-}
diff --git a/sci-libs/libmems/libmems-9999.ebuild b/sci-libs/libmems/libmems-9999.ebuild
deleted file mode 100644
index 782686270355..000000000000
--- a/sci-libs/libmems/libmems-9999.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools subversion
-
-DESCRIPTION="Library for sci-biology/mauve"
-HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
-SRC_URI=""
-ESVN_REPO_URI="https://svn.code.sf.net/p/mauve/code/libMems/trunk"
-
-SLOT="0"
-LICENSE="GPL-2"
-IUSE="doc"
-KEYWORDS=""
-
-CDEPEND="
- dev-libs/boost
- sci-libs/libgenome
- sci-libs/libmuscle"
-DEPEND="${CDEPEND}
- doc? ( app-doc/doxygen )"
-RDEPEND="${CDEPEND}"
-
-S="${WORKDIR}"
-
-src_prepare() {
- default
- eautoreconf
-}
diff --git a/sci-libs/libmems/metadata.xml b/sci-libs/libmems/metadata.xml
deleted file mode 100644
index bdabd1d83788..000000000000
--- a/sci-libs/libmems/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
-</pkgmetadata>