summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-17 16:30:42 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-18 10:01:07 +0100
commita5f3c97a845ed16803503483ac47bb61d9dfdbea (patch)
tree971279180d528b45fe9d9b2177e2479cc7704a07 /sci-mathematics/dataplot/files/Makefile.am.20131220
parentdev-perl/GStreamer: Remove old (diff)
downloadgentoo-a5f3c97a845ed16803503483ac47bb61d9dfdbea.tar.gz
gentoo-a5f3c97a845ed16803503483ac47bb61d9dfdbea.tar.bz2
gentoo-a5f3c97a845ed16803503483ac47bb61d9dfdbea.zip
sci-mathematics/dataplot: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-mathematics/dataplot/files/Makefile.am.20131220')
-rw-r--r--sci-mathematics/dataplot/files/Makefile.am.2013122046
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-mathematics/dataplot/files/Makefile.am.20131220 b/sci-mathematics/dataplot/files/Makefile.am.20131220
new file mode 100644
index 000000000000..85e8c493b80f
--- /dev/null
+++ b/sci-mathematics/dataplot/files/Makefile.am.20131220
@@ -0,0 +1,46 @@
+bin_PROGRAMS = dataplot
+dataplot_SOURCES = dp1_linux.f \
+ dp2.f dp3.f dp4.f dp5.f dp6.f dp7.f dp8.f dp9.f dp10.f dp11.f \
+ dp12.f dp13.f dp14.f dp15.f dp16.f dp17.f dp18.f dp19.f dp20.f dp21.f \
+ dp22.f dp23.f dp24.f dp25.f dp26.f dp27.f dp28.f dp29.f dp30.f dp31.f \
+ dp32.f dp33.f dp34.f dp35.f dp36.f dp37.f dp38.f dp39.f dp40.f dp41.f \
+ dp42.f dp43.f dp44.f dp45.f dp46.f \
+ dpcalc.f dpdds2.f dpdds3.f dpdds.f edinit.f edmai2.f edsear.f edsub.f \
+ edwrst.f fit3b.f starpac.f tcdriv_nopc.f aqua_src.f cluster.f compgeom.f \
+ optimi.f libplot_src.c rldp.c main.f gks_src.f
+
+if ENABLE_GD
+dataplot_SOURCES += gd_src.c
+else
+dataplot_SOURCES += gd_src.f
+endif
+
+if ENABLE_GL
+dataplot_SOURCES += gl_src.c
+else
+dataplot_SOURCES += gl_src.f
+endif
+
+if ENABLE_X11
+dataplot_SOURCES += x11_src.c
+else
+dataplot_SOURCES += x11src.f
+endif
+
+dataplot_CFLAGS = @GL_CFLAGS@
+dataplot_LDADD = @GD_LIBS@ @GL_LIBS@ @X11_LIBS@ $(FLIBS) -lreadline
+
+# this is to remove ambiguity between the similar filenames
+# of the c and f77 version (shortcoming of automake)
+# the f77 versions are forced
+# the c versions objects are called dataplot-gd_src.o etc
+gd_src.o: gd_src.f
+ $(F77COMPILE) -c -o $@ $<
+gl_src.o: gl_src.f
+ $(F77COMPILE) -c -o $@ $<
+aqua_src.o: aqua_src.f
+ $(F77COMPILE) -c -o $@ $<
+libplot_src.o: libplot_src.f
+ $(F77COMPILE) -c -o $@ $<
+rldp.o: rldp.f
+ $(F77COMPILE) -c -o $@ $<