summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-11-16 08:59:54 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-11-16 09:00:10 -0500
commit5dc188ddd7e5ffe6b5afb9154531484a6dd187d1 (patch)
treeb17f27b72f97b5c59fded4dcca39fbfb73e63930 /sci-mathematics/dunshire/dunshire-0.1.1.ebuild
parentx11-misc/nitrogen: Fix sandbox violation (bug #599720 by Toralf Förster). (diff)
downloadgentoo-5dc188ddd7e5ffe6b5afb9154531484a6dd187d1.tar.gz
gentoo-5dc188ddd7e5ffe6b5afb9154531484a6dd187d1.tar.bz2
gentoo-5dc188ddd7e5ffe6b5afb9154531484a6dd187d1.zip
sci-mathematics/dunshire: new package to solve linear games over cones.
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-mathematics/dunshire/dunshire-0.1.1.ebuild')
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-mathematics/dunshire/dunshire-0.1.1.ebuild b/sci-mathematics/dunshire/dunshire-0.1.1.ebuild
new file mode 100644
index 000000000000..0cc06cb07733
--- /dev/null
+++ b/sci-mathematics/dunshire/dunshire-0.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to solve linear games over symmetric cones"
+HOMEPAGE="http://michael.orlitzky.com/code/dunshire"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ local DOCS=( doc/README.rst )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}