summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-04-18 19:25:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-04-18 19:25:53 +0200
commit73c52170e46f94aa54947291e1c31249b32326f5 (patch)
tree95d92945b19dbe5bc7c968c7e5487c72f31da282 /sys-apps
parentsys-apps/hdparm: fix building w/newer glibc #580052 (diff)
downloadgentoo-73c52170e46f94aa54947291e1c31249b32326f5.tar.gz
gentoo-73c52170e46f94aa54947291e1c31249b32326f5.tar.bz2
gentoo-73c52170e46f94aa54947291e1c31249b32326f5.zip
sys-apps/smartmontools: Keep temporarily empty /var/db/smartmontools directory.
This should fix isntallation with paludis. Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/smartmontools/smartmontools-6.4-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-apps/smartmontools/smartmontools-6.4-r1.ebuild b/sys-apps/smartmontools/smartmontools-6.4-r1.ebuild
index 9b4bce3b1fa3..b000e3b6484a 100644
--- a/sys-apps/smartmontools/smartmontools-6.4-r1.ebuild
+++ b/sys-apps/smartmontools/smartmontools-6.4-r1.ebuild
@@ -61,6 +61,8 @@ src_configure() {
}
src_install() {
+ local db_path="/var/db/${PN}"
+
if use minimal ; then
dosbin smartctl
doman smartctl.8
@@ -71,7 +73,8 @@ src_install() {
fi
# Move drivedb.h file out of PM's sight (bug #575292)
- mv "${ED}"/var/db/${PN}/drivedb.h "${T}" || die
+ mv "${ED}"${db_path}/drivedb.h "${T}" || die
+ keepdir ${db_path}
exeinto /etc/cron.monthly
doexe "${FILESDIR}"/${PN}-update-drivedb