summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-08-09 23:57:55 +0200
committerMichael Weber <xmw@gentoo.org>2015-08-09 23:58:13 +0200
commitb7466334251d3715c1a56da1bea3ff5e04fdcfed (patch)
treec2a321512ff078bf8efbf0a1ef28e5ccb24113b0 /sys-auth/libfprint/libfprint-0.6.0.ebuild
parentdev-lang/php: amd64 stable wrt bug 556952 (diff)
downloadgentoo-b7466334251d3715c1a56da1bea3ff5e04fdcfed.tar.gz
gentoo-b7466334251d3715c1a56da1bea3ff5e04fdcfed.tar.bz2
gentoo-b7466334251d3715c1a56da1bea3ff5e04fdcfed.zip
sys-auth/libfprint: Version bump (bug 553242).
Package-Manager: portage-2.2.20
Diffstat (limited to 'sys-auth/libfprint/libfprint-0.6.0.ebuild')
-rw-r--r--sys-auth/libfprint/libfprint-0.6.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-auth/libfprint/libfprint-0.6.0.ebuild b/sys-auth/libfprint/libfprint-0.6.0.ebuild
new file mode 100644
index 000000000000..0c947ac17070
--- /dev/null
+++ b/sys-auth/libfprint/libfprint-0.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils udev vcs-snapshot
+
+MY_PV="V_${PV//./_}"
+DESCRIPTION="library to add support for consumer fingerprint readers"
+HOMEPAGE="http://cgit.freedesktop.org/libfprint/libfprint/"
+SRC_URI="http://cgit.freedesktop.org/${PN}/${PN}/snapshot/${MY_PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="virtual/libusb:1
+ dev-libs/glib:2
+ dev-libs/nss"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # upeke2 and fdu2000 were missing from all_drivers.
+ sed -e '/^all_drivers=/s:"$: upeke2 fdu2000":' \
+ -i configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-drivers=all \
+ $(use_enable debug debug-log) \
+ $(use_enable static-libs static) \
+ -enable-udev-rules \
+ --with-udev-rules-dir=$(get_udevdir)/rules.d
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+
+ dodoc AUTHORS HACKING NEWS README THANKS TODO
+}