summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2020-12-07 18:37:27 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-12-11 09:58:09 +0200
commitdc8edaa92db78c8d861d15f2ee252ed1eb88141f (patch)
treeb36606fd3ba429bf00c4ba7d4e7f581833e82bb2 /sys-auth/seatd
parentdev-libs/libusb: Removed old (diff)
downloadgentoo-dc8edaa92db78c8d861d15f2ee252ed1eb88141f.tar.gz
gentoo-dc8edaa92db78c8d861d15f2ee252ed1eb88141f.tar.bz2
gentoo-dc8edaa92db78c8d861d15f2ee252ed1eb88141f.zip
sys-auth/seatd: Install systemd service file
Closes: https://bugs.gentoo.org/754657 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/18555 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-auth/seatd')
-rw-r--r--sys-auth/seatd/seatd-0.4.0-r1.ebuild (renamed from sys-auth/seatd/seatd-0.4.0.ebuild)4
-rw-r--r--sys-auth/seatd/seatd-9999.ebuild3
2 files changed, 4 insertions, 3 deletions
diff --git a/sys-auth/seatd/seatd-0.4.0.ebuild b/sys-auth/seatd/seatd-0.4.0-r1.ebuild
index 06bf3fce1be6..ab311a6c5986 100644
--- a/sys-auth/seatd/seatd-0.4.0.ebuild
+++ b/sys-auth/seatd/seatd-0.4.0-r1.ebuild
@@ -3,13 +3,12 @@
EAPI=7
-inherit meson
+inherit meson systemd
DESCRIPTION="Minimal seat management daemon and universal library"
HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
-
EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
else
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
@@ -45,4 +44,5 @@ src_configure() {
src_install() {
meson_src_install
newinitd "${FILESDIR}/seatd.initd" seatd
+ systemd_dounit contrib/systemd/seatd.service
}
diff --git a/sys-auth/seatd/seatd-9999.ebuild b/sys-auth/seatd/seatd-9999.ebuild
index 3d89eb8e867b..ab311a6c5986 100644
--- a/sys-auth/seatd/seatd-9999.ebuild
+++ b/sys-auth/seatd/seatd-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson
+inherit meson systemd
DESCRIPTION="Minimal seat management daemon and universal library"
HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
@@ -44,4 +44,5 @@ src_configure() {
src_install() {
meson_src_install
newinitd "${FILESDIR}/seatd.initd" seatd
+ systemd_dounit contrib/systemd/seatd.service
}