summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2022-03-31 19:03:50 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-04-08 15:16:54 +0300
commitd92d7dda74c29c49a54d819b3d716d5fa43eb033 (patch)
tree321856f11a71411dac93486ee297ac701983f544 /sys-cluster/charliecloud
parentsys-cluster/charliecloud: Bump to version 0.27. (diff)
downloadgentoo-d92d7dda74c29c49a54d819b3d716d5fa43eb033.tar.gz
gentoo-d92d7dda74c29c49a54d819b3d716d5fa43eb033.tar.bz2
gentoo-d92d7dda74c29c49a54d819b3d716d5fa43eb033.zip
sys-cluster/charliecloud: Drop old.
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster/charliecloud')
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.25.ebuild84
-rw-r--r--sys-cluster/charliecloud/files/charliecloud-0.24-musl-argp.patch43
3 files changed, 0 insertions, 128 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index 7cd7af9f381b..f94ed53bd21e 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,3 +1,2 @@
-DIST charliecloud-0.25.tar.gz 454041 BLAKE2B 3a071f3b9fb06ca1db6d3b85a577943fe76440d395fdf1415d5085110db665fb75ee09dc14768d326e7e280e6c20096479e5f62290f7dee46821c356f5f18535 SHA512 a7a35b584dbdd6c6e27188d3555173c44f90c0e44fa685a15a47f47c94f9d76aa46ab80054a7c53e10a7f56bef87696f1db2a0eb8c49a388dbb0da0fe9112a60
DIST charliecloud-0.26.tar.gz 472324 BLAKE2B 2b4b8f44f05a497e9367e97e49de255170b610880ef5d7909f7837bc54962f2c2de929d8381b99dc3f4b6124583744993b59839f8f1481cdbd5dc32334d3da9f SHA512 a8638db42a5563723b62ba0e9b9861b41e76b9246b94887d57a8d4c421d9dd2e8c0965b62af166e47859b72a50a2e01ec6775ef13f79c52696a6b2fd95134174
DIST charliecloud-0.27.tar.gz 471754 BLAKE2B b683847a79dd55a4bb79458e94e03988acdff0a1e6a24e7f67d56758bdbc3754cc3609e97bfc778f5cb6ce35d6f4df773235314c2ed642ac796b28b824ecadf6 SHA512 cfa5b1ac923008b9a38fc0228562b31551ea941bf222c9b9e12d8dce4c83ca896893e3509773a5ebc02d6b374d08dc049797226cf1432099aae7174c2bc5ee2b
diff --git a/sys-cluster/charliecloud/charliecloud-0.25.ebuild b/sys-cluster/charliecloud/charliecloud-0.25.ebuild
deleted file mode 100644
index f54e49ec426d..000000000000
--- a/sys-cluster/charliecloud/charliecloud-0.25.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9,10} )
-
-inherit autotools optfeature python-single-r1
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
- S="${WORKDIR}/${P}"
-else
- SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~x86-linux"
-fi
-
-DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
-HOMEPAGE="https://hpc.github.io/charliecloud/"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-IUSE="ch-image doc"
-
-# Extensive test suite exists, but downloads container images
-# directly and via Docker and installs packages inside using apt/yum.
-# Additionally, clashes with portage namespacing and sandbox.
-RESTRICT="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- elibc_musl? ( sys-libs/argp-standalone )
-"
-DEPEND="
- ch-image? (
- $(python_gen_cond_dep '
- dev-python/lark-parser[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ')
- )
- doc? (
- $(python_gen_cond_dep '
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- ')
- net-misc/rsync
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.24-musl-argp.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local econf_args=()
- econf_args+=(
- $(use_enable doc html)
- $(use_enable ch-image)
- # Libdir is used as a libexec-style destination.
- --libdir="${EPREFIX}"/usr/lib
- # Attempts to call python-exec directly otherwise.
- --with-sphinx-python=${PYTHON}
- # This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
- --enable-buggy-build
- # Do not use bundled version of dev-python/lark-parser.
- --disable-bundled-lark
- )
- econf "${econf_args[@]}"
-}
-
-pkg_postinst() {
- elog "Various builders are supported, as alternative to the internal ch-image."
- optfeature "Building with Buildah" app-containers/buildah
- optfeature "Building with Docker" app-containers/docker
- optfeature "Progress bars during long operations" sys-apps/pv
- optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
- optfeature "Mount and umount squashfs images" sys-fs/squashfuse
-}
diff --git a/sys-cluster/charliecloud/files/charliecloud-0.24-musl-argp.patch b/sys-cluster/charliecloud/files/charliecloud-0.24-musl-argp.patch
deleted file mode 100644
index 71817111cdcd..000000000000
--- a/sys-cluster/charliecloud/files/charliecloud-0.24-musl-argp.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 1832d5ff905b16435efa64e458e2ca2f656f0ab5 Mon Sep 17 00:00:00 2001
-From: Oliver Freyermuth <o.freyermuth@googlemail.com>
-Date: Sun, 19 Dec 2021 16:30:27 +0100
-Subject: [PATCH] configure: Add musl compatibility (external argp).
-
----
- configure.ac | 20 ++++++++++++++++++++
- 1 file changed, 20 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index 687d4d4..9f708cf 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -109,6 +109,26 @@ AC_CHECK_LIB([rt], [shm_open], [LIBRT=-lrt], [
- ])
- AC_SUBST([LIBRT])
-
-+# argp_parse, needed externally from libargp / argp_standalone e.g. with musl.
-+# First, check if available in used libc out of the box.
-+AC_LINK_IFELSE(
-+ [AC_LANG_PROGRAM(
-+ [#include <argp.h>],
-+ [int argc=1; char **argv=NULL; argp_parse(0,argc,argv,0,0,0); return 0;]
-+ )],
-+ [libc_provides_argp="true"],
-+ [libc_provides_argp="false"]
-+)
-+# If libc doesn't provide argp, test for libargp
-+if test "$libc_provides_argp" = "false" ; then
-+ AC_MSG_WARN("libc does not provide argp")
-+ AC_CHECK_LIB([argp], [argp_parse], [have_largp="true"], [have_largp="false"])
-+ if test "$have_largp" = "false"; then
-+ AC_MSG_ERROR([*** argp functions not found - install libargp or argp_standalone])
-+ else
-+ CH_RUN_LIBS="-largp $CH_RUN_LIBS"
-+ fi
-+fi
-
- ## Options
-
---
-2.32.0
-