summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-10-24 16:38:28 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-10-24 16:38:40 -0600
commitef99c4775e6802611ac2175a67a8c837cb3d4924 (patch)
tree1aff2977c320203402d39d4a215f61d3c2550546 /sys-cluster/legion/legion-16.10.0.ebuild
parentapp-misc/ckb: Fix dependency on quazip (diff)
downloadgentoo-ef99c4775e6802611ac2175a67a8c837cb3d4924.tar.gz
gentoo-ef99c4775e6802611ac2175a67a8c837cb3d4924.tar.bz2
gentoo-ef99c4775e6802611ac2175a67a8c837cb3d4924.zip
sys-cluster/legion: version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-cluster/legion/legion-16.10.0.ebuild')
-rw-r--r--sys-cluster/legion/legion-16.10.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-cluster/legion/legion-16.10.0.ebuild b/sys-cluster/legion/legion-16.10.0.ebuild
new file mode 100644
index 000000000000..be3148893cd1
--- /dev/null
+++ b/sys-cluster/legion/legion-16.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+CMAKE_MIN_VERSION=3.6
+
+inherit cmake-utils
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="http://legion.stanford.edu/"
+SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gasnet +hwloc"
+
+DEPEND="
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( sys-apps/hwloc )
+ "
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DBUILD_SHARED_LIBS=ON
+ -DLegion_BUILD_EXAMPLES=ON
+ )
+ cmake-utils_src_configure
+}