summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-17 00:21:03 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-17 00:21:03 +0100
commitdc3959609c29c8edf547375ec2587f17082e9ba8 (patch)
tree64194883de6ef3fd056f6f371bb89c4ba98c6c5c /sys-cluster/mpich2
parentsci-calculators/wcalc: port to EAPI 7 (diff)
downloadgentoo-dc3959609c29c8edf547375ec2587f17082e9ba8.tar.gz
gentoo-dc3959609c29c8edf547375ec2587f17082e9ba8.tar.bz2
gentoo-dc3959609c29c8edf547375ec2587f17082e9ba8.zip
sys-cluster/mpich2: disable static libs
Closes: https://bugs.gentoo.org/458474 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-cluster/mpich2')
-rw-r--r--sys-cluster/mpich2/mpich2-1.5.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-cluster/mpich2/mpich2-1.5.ebuild b/sys-cluster/mpich2/mpich2-1.5.ebuild
index e3e96c43c264..ffffb8966367 100644
--- a/sys-cluster/mpich2/mpich2-1.5.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -51,7 +51,7 @@ src_prepare() {
}
src_configure() {
- local c="--enable-shared"
+ local c="--enable-shared --disable-static"
# The configure statements can be somewhat confusing, as they
# don't all show up in the top level configure, however, they
@@ -109,4 +109,6 @@ src_install() {
if ! use doc; then
rm -rf "${D}"usr/share/doc/${PF}/www*
fi
+
+ find "${ED}" -name '*.la' -delete || die
}