summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2016-05-13 13:32:55 -0400
committerMike Frysinger <vapier@gentoo.org>2016-05-13 13:40:31 -0400
commitf2d3d915865c44a0a838e39ba13ee054f9fe2ec3 (patch)
tree01a231e2bd243320b7745560d51c2a3753eaa3f6 /sys-devel/automake/automake-1.15-r2.ebuild
parentsys-devel/automake: rework how HELP2MAN is set up #582734 (diff)
downloadgentoo-f2d3d915865c44a0a838e39ba13ee054f9fe2ec3.tar.gz
gentoo-f2d3d915865c44a0a838e39ba13ee054f9fe2ec3.tar.bz2
gentoo-f2d3d915865c44a0a838e39ba13ee054f9fe2ec3.zip
sys-devel/automake: respect $ED #582734
Diffstat (limited to 'sys-devel/automake/automake-1.15-r2.ebuild')
-rw-r--r--sys-devel/automake/automake-1.15-r2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-devel/automake/automake-1.15-r2.ebuild b/sys-devel/automake/automake-1.15-r2.ebuild
index 8e774977cae5..a2262d26f929 100644
--- a/sys-devel/automake/automake-1.15-r2.ebuild
+++ b/sys-devel/automake/automake-1.15-r2.ebuild
@@ -57,7 +57,7 @@ src_test() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${D}"/usr/share/info >/dev/null
+ pushd "${ED}"/usr/share/info >/dev/null
rm -f dir
# Rewrite all the references to other pages.
@@ -87,13 +87,13 @@ src_install() {
emake DESTDIR="${D}" install \
APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
- rm "${D}"/usr/share/aclocal/README || die
- rmdir "${D}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
dodoc AUTHORS ChangeLog NEWS README THANKS
rm \
- "${D}"/usr/bin/{aclocal,automake} \
- "${D}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version