summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-06-22 14:46:17 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-06-22 14:46:32 -0600
commitdc43ac2896702bebcb536ed1d785b0657b250c9d (patch)
tree82d54881f4b6821314a11d20ec8fd71cf5531367 /sys-devel/byfl/byfl-9999.ebuild
parentmedia-gfx/gimp: CVE-2016-4994 (bug #586666) (diff)
downloadgentoo-dc43ac2896702bebcb536ed1d785b0657b250c9d.tar.gz
gentoo-dc43ac2896702bebcb536ed1d785b0657b250c9d.tar.bz2
gentoo-dc43ac2896702bebcb536ed1d785b0657b250c9d.zip
sys-devel/byfl: fix deps (bug #586736)
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-devel/byfl/byfl-9999.ebuild')
-rw-r--r--sys-devel/byfl/byfl-9999.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/sys-devel/byfl/byfl-9999.ebuild b/sys-devel/byfl/byfl-9999.ebuild
index 8d88af4085ad..c0ffb16d75a3 100644
--- a/sys-devel/byfl/byfl-9999.ebuild
+++ b/sys-devel/byfl/byfl-9999.ebuild
@@ -1,20 +1,18 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit autotools-utils flag-o-matic
+inherit flag-o-matic
if [ "${PV}" = "9999" ]; then
- LLVM_VERSION="3.7.0"
- # Switch to ^b when we switch to EAPI=6.
- EGIT_REPO_URI="git://github.com/losalamos/B${PN:1}.git https://github.com/losalamos/${PN}.git"
- inherit git-2
+ LLVM_VERSION="3.8.0"
+ EGIT_REPO_URI="git://github.com/losalamos/${PN^b}.git https://github.com/losalamos/${PN}.git"
+ inherit autotools git-r3
KEYWORDS=""
- AUTOTOOLS_AUTORECONF=1
else
- LLVM_VERSION="3.7.0"
+ LLVM_VERSION="3.8.0"
MY_P="${P}-llvm-${LLVM_VERSION}"
SRC_URI="https://github.com/losalamos/Byfl/releases/download/v${MY_P#${PN}-}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~amd64-linux"
@@ -38,8 +36,13 @@ RDEPEND="
sqlite? ( dev-db/sqlite:3 )"
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ [[ ${PV} = 9999 ]] && eautoreconf
+}
+
src_configure() {
append-cxxflags -std=c++11
use sqlite || export ac_cv_lib_sqlite3_sqlite3_errstr=no
- autotools-utils_src_configure H5CXX=$(usex hdf5 h5c++ no)
+ econf H5CXX=$(usex hdf5 h5c++ no)
}