summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-01-16 23:00:54 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-01-16 23:00:54 +0000
commit6e8a54c3d2bdcd6aeb7d21d187e2b246a990af06 (patch)
tree3efcec8ee52bfdad9de815e617a64c3fa58c2e8a /sys-devel/crossdev/crossdev-20181202.ebuild
parentsys-devel/crossdev: drop old (diff)
downloadgentoo-6e8a54c3d2bdcd6aeb7d21d187e2b246a990af06.tar.gz
gentoo-6e8a54c3d2bdcd6aeb7d21d187e2b246a990af06.tar.bz2
gentoo-6e8a54c3d2bdcd6aeb7d21d187e2b246a990af06.zip
sys-devel/crossdev: bump up to 20181202
Single change: uclibc tuples now default to uclibc-ng, not uclibc library. Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/crossdev/crossdev-20181202.ebuild')
-rw-r--r--sys-devel/crossdev/crossdev-20181202.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/crossdev/crossdev-20181202.ebuild b/sys-devel/crossdev/crossdev-20181202.ebuild
new file mode 100644
index 000000000000..aba306ab0492
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20181202.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ || (
+ >=sys-apps/portage-2.1
+ sys-apps/portage-mgorny
+ )
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED%/}"/usr/bin/crossdev || die
+ fi
+}