summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-04-22 12:59:41 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-04-22 13:00:43 -0400
commit2680b1fb8a481eda59d7a9feabeb2e4306e221ef (patch)
tree568e86efcc817678602c06671adeca8d5c867a92 /sys-devel/ct-ng/ct-ng-1.23.0.ebuild
parentdev-vcs/tig: Require xmlto for live ebuild (diff)
downloadgentoo-2680b1fb8a481eda59d7a9feabeb2e4306e221ef.tar.gz
gentoo-2680b1fb8a481eda59d7a9feabeb2e4306e221ef.tar.bz2
gentoo-2680b1fb8a481eda59d7a9feabeb2e4306e221ef.zip
sys-devel/ct-ng: version bump to 1.23.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-devel/ct-ng/ct-ng-1.23.0.ebuild')
-rw-r--r--sys-devel/ct-ng/ct-ng-1.23.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-devel/ct-ng/ct-ng-1.23.0.ebuild b/sys-devel/ct-ng/ct-ng-1.23.0.ebuild
new file mode 100644
index 000000000000..42a61e626953
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.23.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit bash-completion-r1
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://crosstool-ng.org"
+MY_P=${P/ct/crosstool}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+S="${WORKDIR}/crosstool-ng-${PV}"
+
+src_install() {
+ emake DESTDIR="${D%/}" install
+ newbashcomp ${PN}.comp ${PN}
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/crosstool-ng-${PVR} \
+ "${D}"/usr/share/doc/
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
+}