summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-11-12 13:09:58 +0100
committerFabian Groffen <grobian@gentoo.org>2017-11-12 13:10:14 +0100
commitaaaa952fdeda1fa2f7c7a61f21063fd42c9d47c6 (patch)
treecabd9707c770fb95ab0dd081b8c09786ee5e787a /sys-devel/m4/m4-1.4.18.ebuild
parentmedia-gfx/wings: Drop some compiler flags (bug #630406). Fix dependencies. (diff)
downloadgentoo-aaaa952fdeda1fa2f7c7a61f21063fd42c9d47c6.tar.gz
gentoo-aaaa952fdeda1fa2f7c7a61f21063fd42c9d47c6.tar.bz2
gentoo-aaaa952fdeda1fa2f7c7a61f21063fd42c9d47c6.zip
sys-devel/m4: add patch to fix crash at runtime on Darwin 17, bug #632500
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-devel/m4/m4-1.4.18.ebuild')
-rw-r--r--sys-devel/m4/m4-1.4.18.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-devel/m4/m4-1.4.18.ebuild b/sys-devel/m4/m4-1.4.18.ebuild
index 1bb440ec6f2a..f249374d1d2b 100644
--- a/sys-devel/m4/m4-1.4.18.ebuild
+++ b/sys-devel/m4/m4-1.4.18.ebuild
@@ -3,6 +3,8 @@
EAPI="5"
+inherit eutils
+
DESCRIPTION="GNU macro processor"
HOMEPAGE="https://www.gnu.org/software/m4/m4.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
@@ -16,6 +18,11 @@ IUSE="examples"
DEPEND="app-arch/xz-utils"
RDEPEND=""
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-darwin17-printf-n.patch
+ default
+}
+
src_configure() {
# Disable automagic dependency over libsigsegv; see bug #278026
export ac_cv_libsigsegv=no